Fatal Error: "Unknown profile version" - 20240303

Operating system


Joplin version


Desktop version info

I cannot access Joplin app.

Sync target



Markdown Editor

What issue do you have?

What the issue is:
Joplin app recently notified me an update and I followed and installed the update yesterday(Taiwan local time), it was fine yesterday, but when I tried to open Joplin app first thing this morning, I got a error message as following screenshot (094912 in screenshot filename).

What I tried:
I tried to search for a solution in Joplin forum via a related search term (1), and when I looked at the result, the result cases are not in similar app setting(Joplin Windows app),and I did not find a clear solution that is close to my scenario.

(1) Related search term:

I tried to download and install several other versions of Joplin app including my original version as in the attached screenshot (143045 in screenshot filename), none of them fix the issue.

What I attempted to do but not yet:
I am thinking to restore the setting from Joplin Backup plugin restoration, but I am not sure if this is a good idea.

What concern me in one of the worse cases:
I am concerned that one of the worse case is that I need to sync everything back to local from Joplin/Dropbox cloud file, I have more than 25000 notes, the first time I synced from local to cloud took days, a waste of lots of time really concerns me.

What I am looking forward here:
I am looking forward to advices of experienced forum members.


You have installed v2.14.15 or later and it has upgraded your local database to version 46. You have then installed an earlier version (v2.13.15 in the screenshot) that can only handle a database of up version 44. You will need to use Joplin v2.14.15 or later.


If you install v2.14.17 and still get an error message please post a screenshot of that error message.

1 Like

Thanks for your reply, I downloaded and installed v2.14.15 and now I can open Joplin app. Appreciate it!

I got three screenshots from three installation, and the first screenshot (file name: 2024-03-03_094912) that I shared earlier is the error message after installed v.2.14.17.e, below are the other two screenshots which I lost track which screenshot is for which installation because the main descriptions of all screenshots are all highly similar:



All the screenshots show the same error which is the one that appears when trying to run v2.13.15 after the Joplin data files have been modified by a later version. Anyway, that does not matter now that Joplin is working.

You did not specifically have to install v2.14.15 just that version or later. You should not have a problem moving to the latest version (v2.14.17).

While I thought the problem was solved, I logged out my desktop computer and log back in for a bluetooth mouse issue, and then the problem remains, not solved, to be sure, I then tried to install v 2.14.17, problem remains, below are the screenshots of the error messages:

As I said it earlier:

So..., during the process of searching for a solution of the main problem of this thread, I spent some time and took a look at how things go when one try to restore his/her notes from Joplgin Backup plugin file, I created a new Joplin profile in a new Windows user account and then import my Joplin Backup plugin file, and it works fine and took only some time within 30 minutes. Except I am not sure what will happen if I sync the restored profile with my Dropbox sync file. Will all the notes becomes double or what? This is one thing that I am concerning, I just had a quick search in Joplin forum and something not very pleasant come to my eyeball.

So now I am taking a second look to the worse case scenario as below:

I am still looking forward a easy way out of this rabbit hole.

Both screenshots show a installation of 2.13.5. Possible you have multiple installation of Joplin on your PC.

1 Like

Thanks for your reply. What can I do to make sure if that is the case or not?

You could start by going to the Windows Control Panel and selecting Programs and Features. See how many copies of Joplin are shown as installed.

Also check your installer for v2.14.17. Right-click Joplin-Setup-2.14.17.exe and then select Properties and then the Details tab. What version does it show?


Also, restoring from a backup will not help you. The problem is with the Joplin app configuration or how many copies you have installed, not your note data. You will not be able to run Joplin to import the backup.

Thank you for your reply.
Surprisingly, there are two installed as shown as screenshot, what is the next step if I may ask?

Right-click Joplin 2.13.15 and select uninstall.

Thanks, I will try. BTW, I missed a part of your shared information, below is the supplement:

I tried to run "Restart Windows 11 and then run Joplin app" three times, it seems to be feasible, I will keep observing Joplin app behavior before I feel that I am on a rock-solid solution.

I'm having a similar issue, except that I only have ONE version of Joplin installed. Version 2.14.17. I am continually getting the same error as the OP.

Unknown profile version. Most likely this is an old version of Joplin, while the profile was created by a newer version. Please upgrade Joplin...

Joplin version: 2.13.12
Profile version: 46
Expected version: 44


I have 2.14.17 installed on two Windows 10 devices and sync via Dropbox.

Joplin opens without issue on one device, but throws this error on the other device.

I have reinstalled 2.14.17 maybe 3 times.

I'm going to try installing 2.14.19 to see if this fixes the problem.

I just discovered that on the machine that throws the error, I somehow have both a per-machine and a per-user installation. It's not obvious from Settings/Apps. I discovered this when I attempted to update Joplin and saw that it was telling me there were both a per-user and a per-machine installation. I edited the path to the executable for the shortcut and it now opens correctly.

I left the start-in directory alone.

I will be updating once I figure out how to remove the per-user installation. :-/

Hopefully, this will help someone else.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.