Export as pdf and markdown jarbled

Hello! I am using the latest version of Joplin and am noticing an odd issue where if I import the database (a tarball of the sync’d filesystem in a git repo) in a build pipeline, it gets jarbled text. For sanity I did an export from the app directly and got the same thing.

Here is an example of what I am seeing (both PDF and MD):

0000007240 13655201277012324 0ustar00000000 000000 
1. Welcome to Joplin! 🗒️

Any ideas on how I could fix this issue?

How do you import the database?

I have tried both exporting JEX directly and also using a sync, which I tarball and then import. Both have the same output

Can you share a tarball that has this issue?

tarball_export.jex (112 KB)

I’m not seeing any issues after importing your file. Neither in Joplin not in exported pdf.

The only thing that’s somewhat similar what you describe is this (the square after the title):

Could you try with CLI? Something like joplin export --format md /joplin/profile/export.md

If that works, could you let me know which CLI version?

I’ll try later today - I don’t have CLI installed right now.

Tried importing your file and exporting using CLI version 1.0.163 (prod) on Linux – still can’t reproduce your issue.
Which version are you using?

That may be the issue, looks like I am using joplin 1.0.149 (prod). I will upgrade and try (was running off a pre-baked docker image)


It worked, I'll publish an updated docker image that works on an automated build :slight_smile:

Great, thanks for confirming.
Out of interest - are you automating import to joplin? From where?

Building out a CI/CD pipeline for notes x) since multiple sync targets aren't supported yet

Edit: well maybe more a CD pipeline but you get the point :slight_smile:

I guess you could say that spellcheck is like a CI but yes I see what you mean.