Error on Windows 10 during npm install

I keep getting an error during npm install, while it's building sqlite from source. What version of build tools do you normally use? VS 2019 fails with an error while building sqlite, saying it can't find VS2015. So I installed that and pointed node-gyp to that version with npm config set msvs_version, and now its saying it can't find the project C:\Microsoft.Cpp.Default.props. Any ideas?

EDIT: here's the full error:

error MSB4019: The imported project "C:\Microsoft.Cpp.Default.props" was not found. Confirm that the path in the <Import> declaration is correct, and that the file exists on disk.
Failed to execute 'C:\Program Files\nodejs\node.exe C:\Program Files\nodejs\node_modules\npm\node_modules\node-gyp\bin\node-gyp.js build --fallback-to-build --module=C:\Users\magya\Desktop\joplin\packages\server\node_modules\sqlite3\lib\binding\node-v83-win32-x64\node_sqlite3.node --module_name=node_sqlite3 --module_path=C:\Users\magya\Desktop\joplin\packages\server\node_modules\sqlite3\lib\binding\node-v83-win32-x64 --napi_version=7 --node_abi_napi=napi --napi_build_version=0 --node_napi_label=node-v83' (1)                                                               

I have the 2015 installed
npm install -g windows-build-tools --vs2015

Witch node and npm version?
I had to downgrade my node because there were problems otherwise.
npm: 6.14.11
node: v14.16.0

Maybe something would help in this doc? Desktop application | Joplin


Thanks for the answers but so far nothing I've tried solved the issue. Now I'm trying to set up a windows vm to see if I can make it work on a fresh install, because I'm starting to think I messed up my laptop with all the things I've tried.

Is it 32 or 64 bit OS, btw? I had similar issues trying to build on win 32 but my VM ran out of disk space while setting up and like you i assumed I had messed up something.

It's 64 bit

I solved it! In the end I ran it in a vm on a fresh install. I installed node v14.16 and at one step I could select to install tools for building native modules. Then everything worked, after running this command to set up the vs command line
call "C:\Program Files (x86)\Microsoft Visual Studio\2017\BuildTools\VC\Auxiliary\Build\vcvarsamd64_x86.bat"
I didn't even have to install windows-build-tools.

I think ticking that option while installing node was the key. Or maybe there was just something wrong in my original system setup.