"Enter" makes a new paragraph Rich editor

I have found some other posts talking about this and I know a way around it is 'shift' + 'enter'

Is there anyway to reconfigure this to something that makes more sense? Naturally with notes, you'll have many lines. It boggles me that the default behaviour is to create another paragraph.

1 Like

Although I do agree, I do understand why it is done this way.

I made a post about it before here - Rich Text Editor Press "Enter" get two carriage returns - #3 by Daeraxa - explaining what I believe to be the rationale behind it but I do also agree that it isn't the 'normal' behaviour one would expect when migrating from a non-markdown system.

I agree it would be nice to have the option and I think there are quite a few people who share this sentiment so if somebody could make a proper justification for it and create PR for then there is a chance it could be considered.

It sounds like it is simply this option within TinyMCE config TinyMCE | forced_root_block

tinyMCE.init({
    ...
    forced_root_blocks: false
});

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.