Convert "->" to "→"

Joplin 2.9.17 (prod, win32), Windows 10

When I installed Joplin about 2 months ago, I am pretty sure I was able to type "->" in markdown, and the rendered text was converted to "→". Now this does not work anymore, but I am not quite since when. I have the same plugins (that are included with Joplin) activated as before. Any idea why this happened?

Have you made any changes to the fonts on your system or the font that Joplin displays? Using a font with "ligatures" can automatically show “->” as “→”.

See this old post about using Fira Code or JetBrains Mono as a font for code blocks.

I do believe I didn't install any fonts during this time, and I don't have selected a font selected in Joplin.
According to development tools, rendered text is using 'Avenir', 'Arial', sans-serif, not sure if if was the same before (since this seems to be the font selected by default).

OK. I mentioned it as I can only recall ever seeing this substitution occurring in Joplin when using a ligature font.

I think you might be looking for the Typographer module? It's in the configuration screen => Markdown

I don't think that the Typographer Module supports arrows:


Yeah, I tried that as well, plus I think it is enabled by default and I definitely still have it enabled.

Right, it seems these arrow replacements are not part of the spec. Most likely some plugin was doing this so you'd need to find which one.

Actually it would be easy to create one using this existing module: GitHub - adam-p/markdown-it-smartarrows: markdown-it plugin that adds more typographic enhancements (like smart arrows)

Here I see the arrow appearing ONLY when I enter it in handwriting on my Samsung pen-enabled tablet.
In this very specific case it does work : I just hand-draw an arrow, the Samsung interpreter turns it into an arrow. And that arrow then appears on any other machine, Linux or Android.
In all other cases (keyboard typing, or any other Android machine, or on the computer) '->' remains '->'

So this means at least the 'nice arrows' are already handled on very Joplin instances, it's only a matter of entering the right character apparently... which is performed by my handwriting recognition on the tablet...

Your Samsung is possibly recognising what you have written and replaced it with a unicode character. You can use unicode characters in Joplin so therefore it would show in your Joplin clients.

Unicode Symbol
U+1F844 🡄
U+1F845 🡅
U+1F846 🡆
U+1F847 🡇

That are many, many more than the few shown above.

1 Like

Since I never could remember the numbers I use these html codes:
Up arrow (↑): ↑
Down arrow (↓): ↓
Left arrow (←): ←
Double headed arrow (↔): ↔
Right arrow (→): →
Right arrow (↠): ↠
North east arrow (:arrow_upper_right:): :arrow_upper_right: North-East
Right arrow (⇒): ⇒

You probably got the patter with the different direction...
By the way, in joplin they look nicer than here :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.