Homepage    |    GitHub    |    API    |    FAQ

Change WebClipper's host and port

I should be a fairly "easy" and needed to be able to configure what host and port webclipper will connect to. I have another machine that is running joplin on the same LAN that I want to use webclipper from. If I could only configure the host ip on it it would supposedly just work.

I tried a workaround thought that caused an unexpected behavior. I ran socat TCP-LISTEN:41184,fork TCP:10.42.0.218:41184 on the remote machine, where 10.42.0.218 is the machine where joplin is running, i was intending to port foward my 127.0.0.1:41184 to the server in order to make it work. But then, when viewing webclipper it said "searching", which it wasn't before, but firefox suddenly used so much ram that I had to restart the machine.

The machine is a ubuntu 20.04 lts. It has low resources. Maybe that is a bug on the webclipper plugin? Is there another tested way i could port forward it....

The webclipper only listens on the loopback interface, thus you have to use a bit of a workaround.

On the machine with the webclipper service do this:

socat TCP4-LISTEN:2006,fork TCP4:127.0.0.1:41184

On your machine with the browser, this:

socat TCP4-LISTEN:41184,fork TCP4:10.42.0.218:2006 

That should do the trick.

1 Like