Center note text or left align by default?

Currently by default the note body is centered and its width is limited to 600 px. This improves readability for large notes in particular. However when the note is just a word or two, it might look weird in the middle of the screen and it seems to surprise even new users.

So I'm wondering would it be better to left align the text? Or is it good as it is, in the center?


For the editor I would think it should be left aligned, on an ultrawide monitor it looks especially odd to have that chasm and I think the setting name "Editor maximum width" doesn't really indicate why changing the width of the editor would centre align it.
It makes more sense for the viewer and rich text editor to be centre aligned as default (if the goal is for readability). My personal opinion of course.


Works well for me as it is.


An alternative would be to style the margins with another (darker) colour. This would give the illusion of a long sheet of paper. This is how document processors get away with centering text.


I like this approach for the reader and richtext editor (providing it can be configured by css). However I do lean towards the "markdown is code" viewpoint in regards to the editor so it would feel a little strange to me to have what is essentially a text editor present as a WYSIWYG/document editor.

Hi, I think that the firts question actually points to somewhere else. So let's suppose that you have only 3 columns opened (Notebooks, Seach and table of contents, Rich editor) now the question is if Joplin provides and option of fixing typed text to the LEFT.

Something like on this picture perhaps?

I upgraded to last version of Joplin Portable Windows 2.3.5 (but same for Joplin Desktop Windows) and all my notes are centered and limited to few picel width like your screen cap.

I almost only use simple text editor mode, no markdown rendering or rich editor or dual view and it completely breaks my usage.

I don't know why this choice has been made (but why not) but I'd really like to know how to revert to the old presentation. I really like to be able to use full screen width


Thank you so much ! I stupidely searched everywhere (@google) before asking this here and you saved me in 20 minutes. I won't do it again :slight_smile:

1 Like

No problem, it has been quite a common topic of late and there have been more than a few different terms used for it, I'm not overly surprised a search didn't return much. It was a pinned topic until a couple of days ago so you just barely missed finding it easily.


Daeraxa is right - thank you for that!
It's actually written in json schema:

This part:

"style.editor.contentMaxWidth": {
			"type": "integer",
			"default": 600,
			"description": "Editor maximum width. Set it to 0 to make it take the complete available space."
1 Like

That's really kind. Thank you again.

1 Like

I just ran into this being a problem. My note has a big table in it, yet the note is completely centered resulting in the table jutting out far to the right, making it look very weird and odd to read.

Attaching the image so you can see, but it looks very unbalanced.

Not only that, when I shrink the page, the contents of the table are cut off, however, the left margin is still very very wide, and should shrink in order to show the table. This may be a bug aside from what you're asking here, but this is what I've encountered.

I have to wonder too if it's necessary to have the margin on both output as well as the editor

Image showing margin to the left and scrollbar to be able to see the table. As mentioned, it's weird to need to scroll to see the table when there's a big margin

1 Like

Maybe I just stumbled onto a pretty straightforward solution, but going into Configuration | Appearance as mentioned by Daeraxa, I saw that the maximum width was already at 0 but my notes were rendering center aligned, which I thought was the OP's original question.
When I clicked the "Show Advanced Settings" button I had the option of editing the Custom stylesheet for Joplin-wide app styles. Opening that in my default CSS editor, I simply added:
text-align: left;
Now all is right with world :slight_smile: