Can't use it in Ubuntu18.04

  1. Download the AppImage package
  2. Use the Joplin_install_and_update.sh to extract the AppImage
  3. Can’t use joplin from Gnome
  4. Run the Joplin.AppImage in terminal, it turned out as the following:
colin@T440:~/.joplin$ ./Joplin.AppImage --appimage-extract
sqfs_traverse_open error

Why are you extracting the AppImage or is that a part of the script?

Because I can’t open it in Gnome, atfter the Joplin_install_and_update.sh runned successfully

Have you tried: sudo apt-get install fuse to see if you can install the package? It’s a common library missing from most distros that the AppImage needs to run. I’m not sure about the specific error you’re receiving though

I have installed the FUSE following this wiki

I’m an Arch user, so my Ubuntu experience these days is super limited. I’m not sure how to fix this issue, but there are quite a few users here that possibly could. Sorry for not being of much help here.

1 Like

What error do you get when you simply run ./Joplin.AppImage

colin@T440:~/bin/joplin$ ./Joplin.AppImage 
open dir error: No such file or directory

I use strace to debug this error and got the following message:

mkdir("/tmp/.mount_JoplinM3DDid", 0700) = 0
pipe([3, 4])                            = 0
clone(child_stack=NULL, flags=CLONE_CHILD_CLEARTID|CLONE_CHILD_SETTID|SIGCHLD, child_tidptr=0x7f2c29a1ae50) = 30827
close(4)                                = 0
read(3, "x", 1)                         = 1
--- SIGCHLD {si_signo=SIGCHLD, si_code=CLD_EXITED, si_pid=30827, si_uid=1000, si_status=0, si_utime=0, si_stime=0} ---
wait4(30827, NULL, 0, NULL)             = 30827
openat(AT_FDCWD, "/tmp/.mount_JoplinM3DDid", O_RDONLY) = -1 ENOENT (No such file or directory)
dup(2)                                  = 4
fcntl(4, F_GETFL)                       = 0x2 (flags O_RDWR)
fstat(4, {st_mode=S_IFCHR|0620, st_rdev=makedev(136, 4), ...}) = 0
write(4, "open dir error: No such file or "..., 42open dir error: No such file or directory

The dir /tmp/.mount_JoplinM3DDid has not be created ?

I download the AppImage again, it run successfully now. Maybe the binary of AppImage was broken.

I’m glad that worked! I did not have anymore suggestions for you, such a weird error.

Thanks for updating with your fix! I hope you enjoy using Joplin!

Any thoughts on implementing a checksum here? That would definitely help make sure the downloads are complete and right. I noticed it’s missing from the script and main download page and should be pretty simple to implement.

Makes sense to me, there probably wouldn’t be any pushback if you wanted to add one.

1 Like

I think I’d only be able to provide for Linux since that’s what I have. Looking into it now. Thanks

@CalebJohn

Joplin is great, I have recommended it to my friends. It’s really hard to download it in China because of the GFW. I spent almost 3 days to download the binary file.

Do you know of any good webhosting that Joplin could use? Maybe we could make a download more available for users in China

AUR is a life-saver. I just love Arch <3

gitee is alternative of github some way, in China