Home / GitHub Page

Error message on 1st launch with Fuse problem

#1

Hi, I’ve retrieved Joplin image with wget -O - https://raw.githubusercontent.com/laurent22/joplin/master/Joplin_install_and_update.sh | bash as per github page.
Had to create a blank file named “VERSION” to proceed.
When launching Joplin image I got a message : fuse
Fuse in installed on my system (Ubuntu 16.04)
Thanks for your help

#2

I’m still fighting to run Joplin. I’ve Fuse installed on Ubuntu and still get messages to install it to run Joplin image.
Does the following tells someone here about what needs to be done ? Thanks
I’ve tried with 2 Joplin images :
Joplin.AppImage 1.0.140
Joplin-1.0.135-x86_64.AppImage

and get the same result.

dd@dd-V-P7H55E:~$ home/dd/.joplin/Joplin.AppImage
bash: home/dd/.joplin/Joplin.AppImage: Aucun fichier ou dossier de ce type
dd@dd-V-P7H55E:~$ --appimage-extract dd/.joplin/Joplin-1.0.135-x86_64.AppImage
--appimage-extract : commande introuvable
dd@dd-V-P7H55E:~$ fuse
Le programme « fuse » peut être trouvé dans les paquets suivants :
 * fuse-emulator-gtk
 * fuse-emulator-sdl
Essayez : sudo apt install <paquet sélectionné>
dd@dd-V-P7H55E:~$ sudo apt install fuse
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
fuse est déjà la version la plus récente (2.9.4-1ubuntu3.1).
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
dd@dd-V-P7H55E:~$ --appimage-extract dd/.joplin/Joplin-1.0.135-x86_64.AppImage
--appimage-extract : commande introuvable
#3

I don’t understand the log above, did you get simply to run the installer bash script?

#4

I did this : Downloading Joplin…
/home/dd/.joplin/Jo 100%[===================>] 97,04M 745KB/s ds 1m 59s
2019-03-16 17:28:00 URL:https://github-production-release-asset-2e65be.s3.amazonaws.com/79162682/28208d00-4374-11e9-8f6b-9cf9a50c8f67?X-Amz-Algorithm=AWS4-HMAC-SHA256&X-Amz-Credential=AKIAIWNJYAX4CSVEH53A%2F20190316%2Fus-east-1%2Fs3%2Faws4_request&X-Amz-Date=20190316T162601Z&X-Amz-Expires=300&X-Amz-Signature=2e1fc0869f7b2eaf65a32340ca392f2f0af4d9fbbdee90d4630fd7007ad66fa9&X-Amz-SignedHeaders=host&actor_id=0&response-content-disposition=attachment%3B%20filename%3DJoplin-1.0.140-x86_64.AppImage&response-content-type=application%2Foctet-stream [101753329/101753329] -> “/home/dd/.joplin/Joplin.AppImage” [1]
OK
Downloading icon…
2019-03-16 17:28:01 URL:https://joplin.cozic.net/images/Icon512.png [28953/28953] -> “/home/dd/.joplin/Icon512.png” [1]
OK
Create Desktop icon.
NOT DONE
Joplin version 1.0.140 installed.
Bye!

and then I doubled click on the Joplin image file. It asked if I wanted to launch it and install the icon, I said yes and then I got the error I needed Fuse and to extract the image which I couldn’t manage to get right.

#5

--appimage-extract isn’t a command, it’s a command flag. So if you actually did want to extract your appimage the command would be

Joplin.AppImage --appimage-extract

Of course this isn’t what you want, you simply want to run Joplin. And based on your above errors it looks like the Joplin.AppImage doesn’t exist for some reason or it’s also possible that the permissions aren’t set correctly.
Do you know if your installation is 32 or 64 bit? It’s possible that you are getting this error because you’re on a 32 bit system.

If your system is indeed 64 bit then you can follow the instructions below:

First we can check if the joplin executable (appimage) is where it should be. Please try

ls ~/.joplin

You should see these 3 files.
image
If you don’t then Joplin downloaded incorrectly and we can troubleshoot that

If they do appear correctly then try running

chmod +x ~/.joplin/Joplin.AppImage
~/.joplin/Joplin.AppImage

Please let me know if this works or if it doesn’t.

#6

Thanks for your help.
I still got a Fuse problem (I may blow one soon…)

dd@dd-V-P7H55E:~$ ls ~/.joplin
Icon512.png  Joplin-1.0.135-x86_64.AppImage  Joplin.AppImage  VERSION
dd@dd-V-P7H55E:~$ chmod +x ~/.joplin/Joplin.AppImage
dd@dd-V-P7H55E:~$ ~/.joplin/Joplin.AppImage
fusermount: mount failed: Operation not permitted

Cannot mount AppImage, please check your FUSE setup.
You might still be able to extract the contents of this AppImage 
if you run it with the --appimage-extract option. 
See https://github.com/AppImage/AppImageKit/wiki/FUSE 
for more information
open dir error: No such file or directory
#8

I am not quite sure what fuse has to do with Joplin.

#9

In any case, this looks like a Linux problem. Your user apparently does not have the permission to mount.

#10

Fuse is something used by appimage, it allows an appimage to mount without having Sudo permission.

#11

Are you sure that you’re on a 64 bit system?

If you are then you can try extracting the appimage.

~/.Joplin/Joplin.AppImage --appimage-extract

Then you can go inside the directory it creates and double click on the joplin.desktop file there.

#12

Thanks for the info. I’ve never used app images on Linux. Interesting concept.

#13

Yes I’m on 64 bit. I’ve done
$ ~/.joplin/Joplin-1.0.135-x86_64.AppImage --appimage-extract

the response starts with

squashfs-root/resources/app/node_modules/lodash/bindAll.js
squashfs-root/resources/app/node_modules/lodash/bindKey.js
squashfs-root/resources/app/node_modules/lodash/camelCase.js
squashfs-root/resources/app/node_modules/lodash/capitalize.js
squashfs-root/resources/app/node_modules/lodash/castArray.js
squashfs-root/resources/app/node_modules/lodash/ceil.js
squashfs-root/resources/app/node_modules/lodash/chain.js

… several hundreds lines in between

end :
squashfs-root/usr/share/icons/hicolor/512x512/apps
squashfs-root/usr/share/icons/hicolor/512x512/apps/joplin.png
squashfs-root/usr/share/icons/hicolor/64x64
squashfs-root/usr/share/icons/hicolor/64x64/apps
squashfs-root/usr/share/icons/hicolor/64x64/apps/joplin.png
squashfs-root/usr/share/icons/hicolor/96x96
squashfs-root/usr/share/icons/hicolor/96x96/apps
squashfs-root/usr/share/icons/hicolor/96x96/apps/joplin.png
squashfs-root/v8_context_snapshot.bin
dd@dd-V-P7H55E:~$

#14

That’s perfect! Now if you enter the squashfs-root directory that was created and double click joplin.desktop you should see the application launch.

#15

Thanks a lot. It’s working !
Next step will be to find out why it won’t sync with nextcloud. Webdav connection is OK but it doesn’t sync anything (it’s working perfectly on my laptop not on this desktop).
Have a nice day