Can't open on MX Linux

I tried installing using the AppImage and the command line. However, when I click on the AppImage or the desktop icon nothing happens. I tried the AppImage first. That didn’t work, so I used the command line install. They both don’t work.


Welcome to the forums. First of all, do you know if Fuse2 is installed? Also, could you copy your terminal output when you try running from command line and paste it here please? Most terminals allow you to highlight and copy with the Ctrl+Shift+C keys.

Don’t forget to add a > with a space to the front of it please? That makes it easier to read.

See this posting, might be related:

1 Like

How do you run from the command line? I didn’t install the command line package. But I can try that next.

I don’t have fuse2 installed. Do I need it?

Is there a solution to this problem?

If you have the AppImage downloaded

  1. Open your terminal
  2. cd /path/to/AppImage
  3. chmod +x Joplin*.AppImage to maje executable from termi
  4. ./Joplin*.AppImage to run

If Fuse2 is not installed, please install it. It’s an AppImage dependency for thus particular one.

Is there any easy way to install Fuse2 on Debian? I installed Fuse2fs Is this the correct package?


I’m taking it you are extremely new to Linux? I’m not a Debian user and have barely put my foot into modern Ubuntu and its derivatives (last time I used Ubuntu was back in 2014 and so much has changed). And, since MX is a Debian based distro, they may have a different packaging system than apt installed.

Here’s a link to the official Users Manual for all MX Linux releases. Just choose the one that you are currently running and scroll down to Basic Usage and Software Management to get an understanding of how MX handles your day to day tasks and whatnot. I would also highly recommend joining their forums and scouring Youtube.

I followed the instructions above and got this error:

$ ./Joplin-1.0.179.AppImage
[20796:0202/] The SUID sandbox helper binary was found, but is not configured correctly. Rather than run without sandboxing I’m aborting now. You need to make sure that /tmp/.mount_JoplinNa8zVL/chrome-sandbox is owned by root and has mode 4755.
Trace/breakpoint trap


root@dell-inspiron:/home/dustin/Documents/Appimages# ./Joplin-1.0.179.AppImage
[20917:0202/] Running as root without --no-sandbox is not supported. See
Trace/breakpoint trap

@yogaturtle, the error that’s showing above is the same bug here:

It’s been acknowledged that this is a Debian bug with how they handle permissions and is not something the devs here can fix. If you are interested in discussing that part more, feel free to post on that issue I linked above since others have been discussing it.

I wouldn’t call that a Debian bug, but a decision made by the Debian devs to patch their kernel to achieve more security!

1 Like

The easiest way to install and also update Joplin on MX Linux is to use this script in the terminal:

 wget -O - | bash

Because of the Debian kernel patch you need to run this command in the terminal to actually get Joplin to run:

sudo sysctl kernel.unprivileged_userns_clone=1

and if you don’t want to enter that last command every time you reboot you can add it to /etc/sysctl.conf


See, not a Debian user. Thanks. :sweat_smile:

This worked. Thank you, OP should accept this answer so that it gets highlighted

1 Like

As an MX-Linux user and having just encountered this sandboxing problem with the latest release of Joplin, I found on the their Forum with regard to another app but requiring sandbox as well that you can easily activate this feature using the MX Tweak tool which automates this tweak on startup. It’s found in the last section under “Other”. Hope this might simplify life for MX-Linux users who enjoy the wonderful facility of Joplin as a note-taker app.