Cannot sync between Android app (2.6.3) and AWS S3

I recently installed the Android app version 2.6.3 and tried to sync it with an AWS S3 bucket. The bucket has a backup of my notes from my desktop, version 2.1.9. My Android version is 10.

When I tried to sync the Android app an orange banner appeared saying "The sync target needs to be upgraded. Press this banner to proceed." Then an error appears saying "Invalid lock client type".

I know the desktop client syncs with the S3 bucket correctly; I can see the changes in the AWS console. I've attached a screenshot of the error message. The app won't let me copy and paste.

Does it work if you upgrade to v2.6 on desktop and upgrade the sync target from there?

I updated the desktop client to 2.5.12 (the latest stable) and let it upgrade the sync target. It was able to sync, but the Android app gave the same error. I then tried with desktop client 2.6.4. It didn't upgrade the sync target, but was otherwise the same; the desktop client can sync, but the Android client returns the same error.

Edit: It's working now? I was looking at the Android app and all of my notebooks are there (I hadn't thought to open the sidebar). If I make a change in the app and let it sync, and then sync the desktop client the change appears. And changes made on the desktop show up in the app. The app still shows the orange banner and the error message, though.

Sorry I didn't follow your explanation. If you've successfully upgraded the sync target from the desktop app, you won't need to do it from mobile, so there shouldn't be any error anymore.

If there's an error in the desktop app too, we need the full error message.

There is no error on the desktop app. The Android app still shows the orange banner, and pressing it results in the error message. Syncing works correctly on both.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.