Android: Error: Joplin Server v2.6.0 is required

When I try to sync on Android, I get this message:

Error: Joplin Server v2.6.0 is required but v2.1.6 is installed. Please upgrade Joplin Server.

Is it possible my Android app auto-updated to some beta version by accident? How do I check that, and stop it from happening again?

I think I've installed from APK once because of some bug, but I haven't touched it since; I'm not sure what the behavior is there.
Since I don't want to take risks with my data, I am hesitant to just upgrade the Server to non-stable versions, even though I do see some 2.6.12 on Docker Hub already.


2.6 is stable actually so you can upgrade. Because Joplin Server is specific to Joplin there might be time where a server upgrade is required.

And if you get this message, there's nothing beta about the app or the server. It's only possible when both are production ready.

Thanks! The update went off without a hitch.
I don't mind upgrading the server - in fact, I try to keep everything I host reasonably up-to-date.

Then maybe the tagging is a bit suspect? I have upgraded the server from 2.1.6-beta to 2.6.12-beta.

These tags on Docker Hub are available:

That seems to suggest the 2.6 line is in beta, and hasn't been moved to latest yet.

I believe /latest is 2.6

the :latest tag is same as :2.6.10-beta.

can you update the :2 tag or create a :2.6 tag like you did with :2.5?

the impression I'm getting is that 2.6 is still in beta because of the tags. currently this means the latest mobile version is incompatible with the latest server version.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.