Homepage    |    GitHub    |    API    |    FAQ

Ability to turn off line wrap in the Markdown Editor

Continuing the discussion from Editor font size and non-wrapping mode on both Desktop & Mobile:

The majority the previous post was regarding font selection. I'm submitting this post to ensure that the request to turn off line-wrap in the editor was not lost in the discussion.

I work with tables that contain multiple columns with html links. The width of the rendered tables are perfectly reasonable. But editing the tables where table rows are wrapped over several lines is pure misery. Tables that have only 4 or 5 rows can be wrapped over 50 lines.

I could use the WYSIWYG editor, but my notes frequently have multiple tables dispersed between blocks of text. I really need to type/copy/paste in markdown.

Please considered having an option to toggle line wrap (horizontal scroll).

There are a few things that maybe you can already do:

  • Switch off the editor max width setting (Config > Appearance)
  • Hide the viewer panel
  • Hide the side bar and note list (Under View menu)
  • Maximize the application window

That should already give you plenty of space for whenever you need to edit these large tables.