Weird space when typing

Joplin 1.0.245 (prod, darwin)
MacOS Catalina Version 10.15.6

Hi, new user here, I’m just wondering why there’s weird space when typing… The more I type the larger the space gets…

Is this normal?

@gressen welcome to the forum.

It looks like your editor font is not set as a monospace font.

If you look at the Editor Font Family section in Tools > Options > Appearance you will see its says,

This should be a *monospace* font or some elements will render incorrectly. If the font is incorrect or empty, it will default to a generic monospace font.

(My emphasis)

The wording there should really be stronger and say you must use a monospace font, but I changed it without being conscience of the fact that the ace editor was still the default.

@gressen you can either change the font or switch to the beta editor (which supports non-monospace font)
Tools -> Options -> Note -> use CodeMirror

Ok, thank you! I chose one of the fonts here and it solved the problem:

I did read that notice but I didn't do my research on what monospace font I could use, and I didn't know how incorrectly it would render. :slight_smile: