Vim as external editor window not opening

  • Version 2.8.8 sync version 3
  • Both markdown and Rich Text
  • Fedor 36 Workstation with Gnome 42.4

Options > General > /usr/bin/vim
apllied and restarted application.
When open in external editor (ctl+E) the vim window is not opening

The vim process seems to be on as shown by ps aux | grep vim

[sherab@fedora ~]$ ps aux | grep vim
sherab     18815  1.3  0.0 232512 11404 ?        Ssl  15:50   0:00 /usr/bin/vim /home/sherab/.config/joplin-desktop/edit-543508b584934f2f96c785ab7ad891b1.md
sherab     18830  0.0  0.0 222168  2136 pts/0    S+   15:50   0:00 grep --color=auto vim

Any advice on how to get the vim window open ?

Edit:
When I remove the /usr/bin/vim from the text editor command in the Tools > option then the gedit text editor (default in Fedora) does open externally.

Vim is a terminal based editor so you have to launch a terminal first.
i.e.
Path = kitty
Arguments = vim

or

Path = gnome-terminal
Arguments = -- vim

3 Likes

Thank you @Daeraxa

Note. I have seen some odd behavior with vim and Joplin syncing. If you use HTML at all in your markdown document (like enclose some things in

tags) I have sometimes had vim save and exit just fine but the changes not show up in Joplin. It's a complete mystery to me why this happens, but it has happened with me.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.