Unshare notebook after return from Joplin cloud to own server

I tried Joplin cloud with a Pro account and shared a notebook.
Then I changed the sync back to my own server. (1)
However, the shared notebook remains shared and I can no longer sync it to my own server.

Is there no way back?

(1) I stopped my Joplin Cloud test after I found that I cannot share the notebook with a basic Joplin account. Unfortunately, there was no mention of this.


Joplin 2.6.10, MacOS 10.15.7

Can't you unshare it?

... searching for and: it’s right before my eyes. Sorry.
Until now I read „can not share ..“, but it is also „... can not collaborate“.

I allways understood it as: you can not actively share a notebook on which one can collaborate, but you can collaborate on a shared notebook of a Pros’s account. So it was my misunderstandig.


(Laurent: Can't you unshare it?)
But just saw that my subscription ended today just some hours ago.
Had not checked that before.

I assume, I can unshare it, when I start a new subscription, sync and the unshare?

Hmm, I don't know as I didn't really consider this case of having a shared notebook and switching the sync target. So what happens when you try to unshare? Or is the option just not available?

The „unshare“ option is not available. It should be, were the share option exists ...?
At this place the menue option shows: „Leave notebook“ and when used, it says:

This will remove the notebook from your collection and you will no longer have access to its content. Do you wish to continue?

Maybe the problem exists ’cause I am still unsubscribed? Tried to subscribe into my account again, but there is no option to do that. The „manage subscription“ has vanished …

## How can I manage my payment details?[🔗](https://joplincloud.com/help#how-can-i-manage-my-payment-details)

To update your card or other payment details, click on the [Profile button](https://joplincloud.com/help#how-can-i-change-my-details), then scroll down and click on "Manage subscription".

helpless …

I don't know about the subscription, but for the notebook the easiest would be to export it as JEX, then delete it. And finally import it back. The export shouldn't preserve sharing metadata so you'll get back a regular notebook.

I tried that before posting my question. Does not help:
the re-import is „shared“ like before (shared symbol)

If I open the .jex file in BBedit I see, that some notes have a share_id, but most don’t:

is_shared: 0
share_id: vIAKC8Cq2SAXKrJcx6UzJCki78QJ7FO7

It looks, as if this is the case with the shared main notebook, subnotebooks and image files (.png, .jpg)

There was no solution for this issue.
Maybe it happend, because I did not „unshare“ the notebook as long as my subscription lasts. After the end of the subscription it was not possible to „unshare“ the notebook.
There seems no way, to re-activate the subscription, once you ended it.

I had to copy all my notes from the „un-unshareable“ notebook by hand.

One issue is that share_id should not be part of the exported note. I thought it wasn't but looks like it is (I'm going to fix that soon). In the meantime you could export as Markdown+FrontMatter to preserve as much metadata as possible, then import this back.

Thank you for your advice. I can use it next time.

Joplin is a wonderful tool. Hope, that "my" issues will help to make it even better.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.