Unable to Install on MX Linux

I tried to install Joplin on MX Linux 23 using "wget -O -........sh | bash
But unable to install it.
Error.: Connection time out.
Thanks in advance.

@Zeno394 welcome to the forum.

Have you tried an install since posting the above? A connection time-out could mean that when you tried to install Joplin there was a problem with your ISPs DNS or the GitHub servers in your region were unavailable.

Sorry, I trued again bit no success.

In case of problem with DNS and local server , can you guide me how to resolve it?

If it was an ISP DNS Server problem then it would be up to your ISP to fix. If it was a GitHub availability problem it would be up to Microsoft to fix.

Joplin is installed by running

wget -O - https://raw.githubusercontent.com/laurent22/joplin/dev/Joplin_install_and_update.sh | bash

which downloads Joplin_install_and_update.sh from raw.githubusercontent.com and sends it to bash to be processed.

Assuming that your MX Linux machine has Internet access, what do you see when you open a command line on the MX Linux machine and type

ping -c 10 raw.githubusercontent.com

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.