Homepage    |    GitHub    |    API    |    FAQ

Sync with Icedrive WebDAV

I'm trying to Sync Joplin to my Icedrive account with the WebDAV address they've given to copy-paste.
When I sync in Joplin it gives me this error if I add on the file location "/Joplin":
Completed: 14/02/2021 20:03
Last error: Error: MKCOL locks/: Parent node does not exist (Exception Sabre\DAV\Exception\Conflict) (409): <?xml version="1.0" encoding="utf-8"?> <d:error xmlns:d="DAV:" xmlns:s="http://sabredav.org/ns"> <s:sabredav-version>4.0.0</s:sabredav-version> <s:exception>Sabre\DAV\Exception\Conflict</s:exception> <s:message>Parent node does not exist</s:message> </d:error>

When I sync without that folder extension I get this error:
Completed: 14/02/2021 20:06
Last error: Error: PUT locks/exclusive_desktop_952346ad67ca49c698a79b7e9bd7458f.json: Unknown error 2 (429):

I'm not sure what the errors are telling me to do. I'm using my email address as the login and Icedrive gives me an access key and tells me to use it as the password in the WebDAV client. What am I missing... why isnt it working?

Using Windows. Joplin version 1.7.11

@gonzalezgg welcome to the forum.

Problem 1

Have you manually created the "Joplin" folder in Icedrive?

This is from the Joplin FAQ for Nextcloud but the same should apply

Do not forget to add the folder you've created to that URL. For example, if the base the WebDAV URL is "https://example.com/nextcloud/remote.php/webdav/" and you want the notes to be synced in the "Joplin" directory, you need to give the URL "https://example.com/nextcloud/remote.php/webdav/Joplin" and you need to create the "Joplin" directory yourself.

Problem 2

When you sync without using a "Joplin" folder you sync into the "root" of your webdav accessed storage and this seems to connect. However a 429 error (if that is what the error is showing) suggests that Icedrive has imposed rate limits on the connection. Especially when first syncing Joplin transfers many, many files very quickly and it could be that Icedrive is not allowing that to happen due to their modification to Webdav.

Can any other Icedrive users comment?

1 Like

Hi,

I just stumbled across this post through a google search.

I've opened a ticket with Icedrive support in december 2020. I've provided them with the exact error message for Joplin (i also had difficulties with Enpass).

Their final answer came after a few days:

Hi Laurens,
We're sorry to say that as of Jan 1st we have decided to drop WebDAV support, in some reason due to the problems you are experiencing above - It is a very old protocol and many 3rd party apps just dont use it properly, or use it differently. It is best not to support it since it produces so many problems for so many users. If you are looking for sync, our own software will do what you want and more, without the problems you have

It's incredibly bad customer support, especially since on their own website they (still) state:

Icedrive fully supports the WebDAV (World Wide Web Distributed Authoring and Versioning) protocol.
https://icedrive.net/help/account/does-icedrive-support-webdav

It seems Icedrive doesn't really care about WebDAV or about their customers very much.. Ashame you only find out after subscribing.

So far i've tried a lot of things (create folder structure etc) but nothing seemed to work. Another app (Orgzly) managed to create a folder structure and save notes without problems though (through WebDAV on IceDrive).

Edit: One more addition, i just setup Genius Scan (android app) to sync over WebDAV. This works flawless, it even pulls the folder structure and let's you browse through. Possibly it would be something that Joplin could improve?

Edit 2: I have just installed the latest version of Joplin and tried once more. When I test the configuration in the setting i get a succes message (already better than before), however when trying to sync it shows the following error:

Completed: 26/02/2021 15:14
Last error: Error: PUT locks/exclusive_desktop_227e5505875b496ca256b12221f29df0.json: Unknown error 2 (429):

Same error as the OP. The first error (MKCOL locks is no longer occuring). I've tried syncing to root, and syncing to a pre-created folder. But to no avail so far.

Edit 3: Joplin did manage to create two folders when syncing to root. One is called 'Locks', the other is called 'Temp'. Both folders are empty.