Sync issue and more (Linux -> Windows)

I've got about 500 notes, joplin-desktop directory size is 361,8 MB.
I sync notes with OneDrive with E2E enabled.
My main OS is Ubuntu but I'd also like to have an option to read my notes on Windows sometimes. And there's a problem.

After a fresh install on Windows syncing is starting and after a while notes appear one after another, but at some point I'm getting a sync error:

Error log:
Untitled-1.yml (4.3 KB)

And as you can see, the icon in the taskbar becomes blank just after this error.
At this point some of my notebooks still not showing up.
Then sync starts from the beginning with the same result and then again and again.

After reinstalling, the icon remains in place until the same error occurs.

I haven't found in sqlite db any records related to note mentioned in error "001d848873ac464884bf28942ae3f314". So I can reproduce the error with my own database but сan't figure out which note is the problem.

I would be grateful for any help and ready to provide additional information.


Windows 10 fully updated
Joplin 2.7.15 (prod, win32)
Client ID: 36a9d173022844239069284f8d3ec5c3
Sync Version: 3
Profile Version: 41
Keychain Supported: Yes
Revision: 8352e23


Ubuntu 22.04
Successfully synced despite the problem in Windows, thanks God I didn't lose anything.

Joplin 2.7.15 (prod, linux)

Client ID: dc082c1d537a4cf39bd27a9ee9f71b31
Sync Version: 3
Profile Version: 41
Keychain Supported: No

Revision: 8352e23


iOS
Successfully synced.