Some items cannot be synchronised

Operating system

iOS

Joplin version

12.14.8

Sync target

Joplin Server

What issue do you have?

I've seen this topic come up before, but nothing answered my specific problem. I'm running Joplin on a Mac (2.14.22) and an iPad (12.14.8). All is fine on the Mac. On the iPad, however, I get the warning shown in the attached screenshot. It refers to three PNG files that are NOT files I've attached to notes. I suspect they might be something to do with Joplin itself (from the names - SubNotebooks.png, AllClients.png and WebClipper.png).

I've tried clicking 'Retry' many times & restarting the app. I've tried searching for the filenames (on both iPad and Mac), with no success. I'm syncing via a locally hosted Joplin Server, which works fine in all other respects.

Any suggestions?

Screenshots

In version 3.0 you can ignore such cases to prevent the orange banner to appear. But with the current version I don't think there's an easy fix, especially on mobile

In the end I deleted and reinstalled the app on iPadOS. Annoying but not too time consuming. It reloaded all the notes from the server just fine.