[SOLVED] Debian 12.5 install just crashes

Operating system

Linux

Joplin version

3.0.12

Desktop version info

The app doesn't launch...

Sync target

File system

Editor

Markdown Editor

What issue do you have?

Installed with the Joplin_install_and_update.sh script, only got a warning "Electron sandboxing disabled", but the icon didn't display on the desktop or in the menu...
Tried to launch it from the terminal, the machine started to lag and I had to perform a hard shutdown as it was totally freezed.

Odd. I installed Joplin today on my Debian 12.6 (it was updated yesterday from 12.5) instance and it seems so far to work fine. It was installed from the software app store in Debian 12 as a Flatpak not from a script as indicated by the OP.

Joplin 2.14.22 (prod, linux)

Client ID: 2e59fec76c294915b02e77af4ab4d3ba
Sync Version: 3
Profile Version: 46
Keychain Supported: No

My only niggle is that I use dark mode but have been unable to invoke dark mode in the app (if someone has advice on this, would be useful).

For dark mode Joplin with dark mode system defaults, try Tools > Options > Appearance > check Automatically switch theme to match system theme.

If that doesn't work or you want to use a different theme, uncheck it and manually set Theme to the desired dark theme.

1 Like

@muzak Oh my days! I just didn't explore enough. Thanks so much.

Thanks Graham! The official site only mentions the installation script, can you please point me to the Flatpak procedure? By the way, the app store on my machine doesn't find any software named Joplin... :thinking:

Yes of course. You can access it via the flathub website.
I'm not able to add links unfortunately so can't point you beyond suggesting a search for "Install and use Flatpak" in your browser.

This is the entry I made as a reminder about installing Flatpak which should allow you to access it from your Software app:

Thanks a lot! I managed to install and run the app, although the main menu icon seems to be inactive (clicking on it does not launch the app)! I'll probably have to reboot first...
Thanks again for your help!

1 Like

Yes, rebooting the system is a necessary step.
Glad to have been of some help..

@jlgarnier Did the reboot work?
You should also be able to launch it from terminal using flatpak run net.cozic.joplin_desktop

Not to try to put you off using the Flatpak by any means but just to clarify - the Joplin site only "officially" distributes the AppImage version, which is why you won't see Flatpak mentioned front and centre.

Anything else is covered in Unofficial Alternative Distributions

Thanks for the information! Actually, the official installation (script) failed miserably so I'll stick with the Flatpak way until I understand what's going on in the lower layers...