Serif font in Joplin Editor

Operating system


Joplin version


Desktop version info

Joplin 2.14.19 (prod, linux)

What issue do you have?


Joplin is a good software for me, with a small but serious obstacle. I find it difficult to read longer texts without serif fonts. So I tried to change the font, but so far without success. First I tried the settings:

(My config: Joplin 2.14.19, Linux Mint 21.2)

Editor font family: DejaVu Serif
Editor monospace font family: FreeMono

Joplin continues to work with sanserif :frowning:

At next I looked for tips on the net and tried the following in userchrome.css:

body, th, td { font-family: DejaVu, FreeSerif, Liberation, Noto, serif; font-size: 13pt; font-variant-numeric: tabular-nums; color: black; }

Joplin continues to work with sanserif :frowning:

Next, I looked at the log (Menu->Help->Toggle Development Tools) and found the following problem:

PromptDialog.tsx:70 [Intervention] Slow network is detected. See (http...) chromestatus com feature 5636954674692096 for more details. Fallback font will be used while loading: (file...) mount_JoplinK0CSmm/resources app.asar vendor lib roboto-fontface fonts roboto Roboto-Bold.woff2 (slashes deleted)

Please, what else can I do to make the Joplin editor use serif fonts?

I use Windows and when I change the Editor Font Family to Times I get the serif font. I don't have the DejaVu font so I can't check that.

I recognized the problem. Joplin doesn't handle all fonts, at least in Linux. Either because they have multiple cuts or because they contain spaces in the name.
Now I'm using the font "FreeSerif" and it shows up in the editor.
The next act is to use serif fonts in the rendered text. But it's hard for me to deal with this userchrome.css.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.