Running Joplin Server on Unraid

Have been using Joplin for a while and I really love it!
I'm new to Joplin Server but also new to Unraid and Docker. This is my first time using postgres.

I got this all working with a reverse proxy maybe 2 months ago. Had a really hard time figuring it out but eventually worked. A change to my unraid server hosed the containers using postgres. Not knowing much about postgres, I figured I'd just wipe it all out and start over again.

Set it back up, but not really positive about all the settings that I put in. Now I'm mostly getting errors like 502 Bad Gateway error which leads me to believe it might be a reverse proxy problem maybe? I can't figure out how to troubleshoot this to see where the problem is.

I was hoping someone might take a look at my settings, and see if I'm missing something obvious.
Joplin Server v2.3.5

Joplin Server settings in Unraid

I used this to set up Postgres 11


I'm using Nginx Proxy Manager for reverse proxy
I have images if needed, but I can only embed one image per post :smiley:

I think that's it. The containers are all set to use a proxy network that I configured from a spaceinvader one video. I think it would be better for joplin and postgres to talk on their own network, but that's my next goal.

Just want to say that with Nginx Proxy Manager and the latest Joplin server docker (later than 2.1), it never redirects correctly to my internal IP address. But with Caddy everything goes smooth.
My configuration is unRaid 6.9.2, Caddy docker (hotio/caddy), Joplin server (joplin/server:beta), and postgres (postgres:latest).

I'm not married to nginx proxy manager and happy to try Caddy out. Are you using Postgres11? Anything wrong with the way I set up my database as pasted above? thanks in advance!

would you mind sharing what your caddyfile looks like for joplin so I know I have that part squared away correctly?

Postgres 13.4, I love to keep everything up-to-date :slight_smile:

Caddyfile is quit simple:

(tls_conn) {
        tls /config/ssl/fullchain.pem /config/ssl/privkey.pem

(log_file) {
        log {
                output file /config/logs/caddy_{args.0}.log {
                        roll_size 50mb
                        roll_keep 30
                        roll_keep_for 720h
                format json
                level DEBUG
} {
        reverse_proxy internal_ip:22300
        import tls_conn
        import log_file notes

Port 8443 is the one defined in the Caddy container's configuration, not the real one that is used to access from internet.
But the log seems not working well, anyway I never check the logs since Caddy works really stable.

If you think the problem might be in your reverse proxy, have you changed your Network Type to a local network and tried to connect a Joplin client to that IP address? I've been using unRAID since before they added Docker and have had my fair share of bumps setting up new Docker images. When you're troubleshooting a potential host of issues, it's nice to be able to set some lines in the sand and know it's not from A to B so it must be from B to C. If you try the local IP address, you'll know you have your Postgres setup correctly, and your connection to the Postgres container setup correctly.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.