Rule MD041, should always start with h1

Operating system


Joplin version



Markdown Editor

What issue do you have?

vscodium plugin markdownlint is checking for First line in a file should be a top-level heading. Rule MD041.

Now following that all Joplin title starting with a # like “# Linux OS”

Is there a way to hide the # in Joplin, or do I have to disable MD041 rules?

source MD041

1 Like

Could you give some more context? I guess this is not about the markdown editor in Joplin, but rather about exported markdown or the VSCode plugin?

1 Like

I'm usually all for MIME types and magic headers identifying files like Linux rather than extensions like Windows, but on this one I feel like the extension is the only thing that should actually matter.

Millions of text files start with #, a good example would be programming languages, or keeping it within Markdown, license files.

And these aren't headers, they're to allow you to copy it into source code without messing with the compiler. Otherwise every single paragraph is a header and they have no actual body text.

The linked document even goes on to say "you can use HTML headers instead because Github", well, where's my <!DOCTYPE html> as per HTML specs? Who's rules are we following here? (And yes I'm aware the doctype is also optional!)

Ultimately it seems like a good spirit as a general principal but outright refusing to operate on a file unless it either begins with a non-native tag or a specific character that doesn't even necessarily represent it's purpose "just because" seems like the kind of thing that needs an override.

I could just as easily make MD120 "All MD files should start with their length and checksum values" and it'd have more substance to it than MD041 does IMO.

Well, it's about hiding the # in the title section in Joplin.

My use case is to edit markdown files in vscodium while working on other stuff there, and have Joplin backup and encrypt everything in the background.
At the end, Reviewing does markdown on the Tablet or phone.

I notice that in Joplin the headers are render correctly in the editor sector, but not in the note list or Title area, the hashtag inside the Title stays.

It's no biggie, but if there is a setting or solution to hide the # for h1 in the Title and note list section, I would like to know.