Resources folder deleted accidently and put back, but no resources are displayed

Hello

I have accidently deleted my .resource folder. When I realized I do not have any attachments on my notes displayed, I have put back the .resource folder from another import, but my attachments (image files mostly) are not displayed in Joplin.

Here is an example of a note with missing resource:

$ cat 9d9d2e02884441dcb846712dae2362ba.md
microsoft project professional 2016 ürün anahtarı

![](:/e615fde9477c5d18c738e025df4c2744)

id: 9d9d2e02884441dcb846712dae2362ba
parent_id: 01470419b7a04214aa37cb2f8d0b1611
created_time: 2018-06-14T18:22:38.000Z
updated_time: 2018-06-14T18:22:47.000Z
is_conflict: 0
latitude: 0.00000000
longitude: 0.00000000
altitude: 0.0000
author: 
source_url: 
is_todo: 0
todo_due: 0
todo_completed: 0
source: evernote.mobile.android
source_application: net.cozic.joplin-desktop
application_data: 
order: 0
user_created_time: 2018-06-14T18:22:38.000Z
user_updated_time: 2018-06-14T18:22:47.000Z
encryption_cipher_text: 
encryption_applied: 0
type_: 1

I have checked the sqlite database and resource is there:

sqlite> select * from resources where id='e615fde9477c5d18c738e025df4c2744';
id                                title                           mime        filename                        created_time   updated_time   user_created_time  user_updated_time  file_extension  encryption_cipher_text  encryption_applied  encryption_blob_encrypted
--------------------------------  ------------------------------  ----------  ------------------------------  -------------  -------------  -----------------  -----------------  --------------  ----------------------  ------------------  -------------------------
e615fde9477c5d18c738e025df4c2744  Screenshot_20180614-212132.png  image/png   Screenshot_20180614-212132.png  1539465223966  1539465223966  1539465223966      1539465223966                                              0                   0

I have also checked the resource file and its md file, both are there also:

$ find . -iname "*e615fde9477c5d18c738e025df4c2744*" | xargs ls -la
-rw-r--r-- 1 ebayer users    393 Oct 14  2018 ./e615fde9477c5d18c738e025df4c2744.md
-rw-r--r-- 1 ebayer users 898266 Apr 28 15:44 ./.resource/e615fde9477c5d18c738e025df4c2744

I have also checked and confirmed that I can open the resource file with an image viewer directly.

However I am unable to see the attachment in Joplin. I have already tried exporting the note with jex and importing back, to no avail. I have even tried importing the jex file with a new profile, still can not see the attachment. I have also tried importing the resource file from the enex file that I used to import the resource when I first started using Joplin, and since the resource name is same, the attachment is not displayed again. I can see the attachment when I import the enex file into a clean profile.

Is there a way to fix the .resource folder. Is there some index file somewhere that I miss, or some permission somewhere? How can I fix my resources?

I’m really not sute about this problem, but as a sanity check, have you restarted Joplin? And if you have it’s not just closing to the tray, correct?

Yes, I have checked that it is closed, and I am not using the tray.

Your best bet would be to delete your local profile and sync again.

1 Like

Syncing with a clean profile fixed this, thanks for help :slight_smile: