Homepage    |    GitHub    |    API    |    FAQ

OneDrive Sync issues

  • version: 1.7.11
  • sync-destination: OneDrive Personal
  • desktop-app
  • windows/MacOS

I have the desktop-app installed on my Mac and I'm syncing to a OneDrive. This is working fine. The path in OneDrive is : "Apps/Joplin". - so far so good
I installed the desktop app on windows and wanted to sync. This is failing with:
"Error: Not a valid URL: https://graph.microsoft.com/v1.0/drive/root:/Apps/Joplin 1/info.json:/content"
What I do not understand is the "/Apps/Joplin 1" - this should be "/Apps/Joplin"
I can't seem to change this somewhere. I tried :slight_smile:

  • removing the app from windows
  • deleting /Users//.config/joplin-desktop
    Reinstalled, but it still wants to go for "Joplin 1"
    Installed Mobile(android) app and tried to synchronise, but also there is goes to "Apps/Joplin 1"
    I see there are several similar reports but I'm not sure if they are exactly the same and how to recover from it.

That seems to be an issue with the OneDrive API and how Joplin registers with OneDrive. If there is a problem with the API access, in your case that the folder Apps/Joplin already exists its creates a new one names Joplin 1.

On your Mac you are using the build in OneDrive sync right? You are not using filesystem sync to think to a OneDrive folder?

You can check here if Joplin is registered twice in your OneDrive account.
https://account.live.com/consent/Manage

Indeed on my Mac I'm using the build-in OneDrive sync.
I'm not sure how I ended up in this situation. I eventually did a complete fresh install/config:

  • exporting my notes.
  • removing the authorisation and Apps/Joplin folder in OneDrive
  • removing the .config/joplin-desktop folder and on android under Apps, delete data.
  • reconfigured every client 1-by-1
  • imported my notes
    I now have 1 Mac, 1 windows and 2 android devices configured.

Thanks again for your help !

Thats the problem. If you are just syncing with the "build-in" directory Joplin is not registered with the Onedrive API. Because of that a new folder is created when you register a new device for Onedrive sync from within Joplin. The application things that Apps/Joplin is some user created directory that it is not allowed to change.