OCR search not working on synced computers

Operating system


Joplin version


Desktop version info

Joplin for Desktop

Copyright © 2016-2024 Laurent Cozic
Joplin 2.14.20 (prod, darwin)

Client ID: e127c359ad1b4ae3a83d284c85871084
Sync Version: 3
Profile Version: 46
Keychain Supported: Yes

Revision: cfd98e3

Backup: 1.4.0
Hotfolder: 1.1.1
Templates: 2.4.0

Sync target

Joplin Server

What issue do you have?

I have Joplin running on several computers. The "main" one is a Mac mini, where scans from my scanner get dumped and imported. This installation syncs with a Postgres database I run on that machine, and all my other Joplin installs sync to that database.

This works flawlessly on the Mini. However, all my other installs, whether they're on our laptops or on our iPads or iPhones, can't seem to access the OCR info properly. If I search for the word "delta" for example, I will find all the files that have "delta" in the title, but no files that have "delta" in their attachments. On the Mini, they all show up. But on other installs, nothing.

I've looked at the OCR info on my laptop. The OCR data is there. I downloaded the latest beta which lets you look at it directly, and I can see it. So the information is coming over to the laptop. It's just that the search function doesn't find it. I've tried dumping the local data and re-downloading from the database. No luck.

Since it seems to be working on the Mini, it seems that the problem is somehow between the Mini and the database. Somehow, the OCR data is getting on to the database, but the index (or whatever, sorry, not an expert) is not.

One more thing: I exported all the data from the mini to a jex file, then created a new profile and imported it. Behavior is just like what I see on the laptop: search returns no OCR results. Which tells me, I think, that the problem is with the database on the Mini itself. When I export the data, either through sync or by making a jex file, for some reason the OCR search info does not come through, even though the OCR data does.

Anyone seen this? Any ideas how to troubleshoot?

1 Like

Is there any way to force a re-build the index or alternatively, do re-do the OCR, other than exporting and reimporting the notes individually?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.