Notes not showing up after install and sync

Operating system

Windows

Joplin version

2.14.22

Desktop version info

Joplin 2.14.22 (prod, win32)

Client ID: c2XXXXXXXXXXX9
Sync Version: 3
Profile Version: 46
Keychain Supported: Yes

Revision: e579eb9

Backup: 1.4.0

Sync target

Joplin Server

What issue do you have?

Hi all. I just installed Joplin on windows 11 x64 and setup sync within the settings(including the master key it asked for) and Joplin shows it sync'ed properly but only 1 note from another machine is shown(and none of the notebooks from other machines show). When I open Joplin on another machine(an iPhone) all my notes are there AND the default welcome to joplin notes from the fresh windows install are shown.

A bit more info that may be relevant:
I'm self hosting Joplin server and have been for some time. About 4 months ago the server hosting it died and I just got around to re setting it up. I have an iPad, and iPhone, and a Pixel phone all using Joplin server to sync. I reconfigured Joplin server and then edited the settings in each joplin app to reflect the new server settings and verified that all the devices can sync back and forth(I created a new note on one device and then verified it showed up on all the other devices and then edited the note and verified the edited version synced back to all other devices) and all worked fine. Then today I went to install Joplin on my laptop and it says it synced fine, but only 1 note appears and no notebooks appear. I tried uninstalling and reinstalling joplin and verifying the sync settings but no notes are showing up on windows. All notes are still on other devices.

Any ideas?