Note Attachments not Found

The majority of my note attachments recently stopped working across multiple platforms: android, linux, mac, and windows. The screenshots below were taken on joplin 1.2.6 for mac.

I recently had a problem with syncing that I thought I resolved by exporting and re-importing my entire database. I think that my attachments worked after this process, but the timing is suspicious. Any guidance would be greatly appreciated.

This is a bug in and old version of Joplin that has been fixed since then, so it's best to get the latest version. You'll still need to manually fix these links as they are saved to the note.

The link should look like this ![](:/fcca2938a96a22570e8eae2565bc6b0b)

best way to fix those links is opening in an external editor and regex find/replace.

Thank you! Can you recommend an editor to use, and also the file that I'd need to open with it?

This really depends on your preference. My editors of choice are vi, Sublime Text, and VS Code.

I don't understand. You go to Note -> Toggle external editing or click on the toolbar icon image

Another way to fix it is to export, perform search and replace to fix links, and import back.

Thank you for the responses. I still can't get it to work. Here an example of an attachment that I've updated:

and I confirmed that the file does exist in the resources folder:


And I'm still. getting the same error:

You need to remove ".pdf" from the link.

Hmmm, I still can't get it. Also, when I change it to that format the link does not seem to render correctly in the MD.

It would show that when the file is not downloaded or decrypted yet.

The file is present in my resources folder and there is nothing left to sync

It would help if you could post actual text and not screenshot. I don't want to manually type a random 32 character long string. You should remove "!" from resources that are not images.


Have you updated to the latest version yet? You never mentioned it.

Yes, I'm at 1.5.14 for mac. I did not mention the version number originally because the issue was occurring on multiple platforms (mac, windows, linux, android). And I just confirmed that the problem persists on windows.

Also, I just realized that I pasted the wrong link above. it is now corrected.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.