Joplin Terminal Installation npm error code E404 on Linux Mint

After running:
NPM_CONFIG_PREFIX=~/.joplin-bin npm install -g joplin

I get:
npm ERR! code E404
npm ERR! 404 Not Found - GET - Not found
npm ERR! 404
npm ERR! 404 '@joplin/lib@^1.0.9' is not in the npm registry.
npm ERR! 404 You should bug the author to publish it (or use the name yourself!)
npm ERR! 404
npm ERR! 404 Note that you can also install from a
npm ERR! 404 tarball, folder, http url, or git url.

npm ERR! A complete log of this run can be found in:
(The complete log is 797 lines long) -

I do not know which version is it for, the page
says I need to run "version" inside of the program..
a line in the errors I got " '@joplin/lib@^1.0.9" might be a clue.

I've installed Node.js (first time doing it, meaning I've attempted to delete
everything and reinstall multiple times, which might've messed something up)
1.curl -sL | sudo -E bash -
2.sudo apt-get install -y nodejs

then tried to install Joplin Terminal by running:
NPM_CONFIG_PREFIX=~/.joplin-bin npm install -g joplin

I'm using Linux Mint, which I believe is based off ubuntu, but I don't know enough to say
if it's the same thing.

I've attempted to uninstall (purge) node completely and install an older version
(Maybe I misunderstood v10+ to mean v11,v12 instead of v10.0, v10.1..)
But the issue persists.

Sorry about that, I'm so optimistic we're going to get the npm @joplin namespace that I've already made the change in the code, but for a second I forgot they didn't give it to us yet. I've now republished a fixed package as v1.4.9. Please give it a try and let me know if it works.

Thanks for the speedy reply, I tried it again:
There were a few warnings during installation, but it completed and I gained
the option to run joplin:
throw err;

Error: Cannot find module '/usr/local/lib/node_modules/joplin/node_modules/sqlite3/lib/binding/node-v64-linux-x64/node_sqlite3.node'
at Function.Module._resolveFilename (internal/modules/cjs/loader.js:636:15)
at Function.Module._load (internal/modules/cjs/loader.js:562:25)
at Module.require (internal/modules/cjs/loader.js:692:17)
at require (internal/modules/cjs/helpers.js:25:18)
at Object. (/usr/local/lib/node_modules/joplin/node_modules/sqlite3/lib/sqlite3-binding.js:4:15)
at Module._compile (internal/modules/cjs/loader.js:778:30)
at Object.Module._extensions..js (internal/modules/cjs/loader.js:789:10)
at Module.load (internal/modules/cjs/loader.js:653:32)
at tryModuleLoad (internal/modules/cjs/loader.js:593:12)
at Function.Module._load (internal/modules/cjs/loader.js:585:3)

Going into /usr/local/lib/node_modules/joplin/node_modules/sqlite3/lib , it seems
the directory "binding" does not exist on my system, but the path previous to it does.

Hmm, not sure why it wasn't built. Maybe try to go in "/usr/local/lib/node_modules/joplin/node_modules/sqlite3" and manually run "npm install"? Or else try to delete the complete "/usr/local/lib/node_modules/joplin" and re-install Joplin.

after attempting to uninstall and re-install everything
the directory joplin does not exist in /usr/local/lib/node_module

Here's what I've done so far:

tried "npm install" in said directory- permission error
tried sudo npm install - worked, but previous error persists ( "internal/modules/cjs/loader.js:638")
deleted the /usr/local/lib/node_modules/joplin
running joplin now says "file doesn't exist" (as expected, I assume)
reinstalled joplin
NPM_CONFIG_PREFIX=~/.joplin-bin npm install -g joplin
no error message.
running jopling - still says "no such file or directory"
trying to install again with sudo
same outcome when trying to run it
uninstalling and re-installing node - (from the v10 version I downgraded to back to v15)
sudo apt-get purge --auto-remove nodejs
then reinstall NodeJs
then reinstall Joplin
despite going through without errors - "file or directory doesn't exist" when I try to run it
tried running the next step in Joplin's installation (which I assume makes a shortcut)
sudo ln -s ~/.joplin-bin/bin/joplin /usr/bin/joplin
ln: failed to create symbolic link '/usr/bin/joplin': File exists
So I went to
cd /usr/bin
ls | grep joplin gives the file "joplin"
attempted to run that:
node:internal/modules/cjs/loader:922 (error 32 lines long:


Digging further into it, I found that running the joplin binary:
cd ~/.joplin-bin/bin
Produces the error:
Error: Cannot find module
Digging into the path provided, I had all of it up to:
but instead of
I have the directory:

I tried renaming it, to see what would happen:

Error: The module '/home/eden/.joplin-bin/lib/node_modules/joplin/node_modules/sqlite3/lib/binding/node-v88-linux-x64/node_sqlite3.node'
was compiled against a different Node.js version using
NODE_MODULE_VERSION 64. This version of Node.js requires
NODE_MODULE_VERSION 88. Please try re-compiling or re-installing
the module (for instance, using npm rebuild or npm install).

attempting npm rebuild did not produce any noticeable change.