Joplin mobile sync lag

I've ran into a friction point when using Joplin on desktop + mobile and I wonder if there are any solutions to it.

Most of the time I use Joplin on desktop and while I'm on the go I use the mobile app to take quick notes.

Every time I open my mobile app, I need to wait for the sync to be done (to avoid conflicts). Only then I can access my notes.

Not a huge deal but can be annoying when you'd like to quickly jot down a thought.

Anyone has suggestions? any way to run the sync in the background once in a while? I'm using onedrive sync

No Joplin has no background sync.

1 Like

Unfortunately it syncs automatically even when the sync intervall is set to "disabled" in the settings.

BUT: Perhaps it helps you to set your app to sync only over Wifi connections - so it won't sync when you're underway.

The problem is that Android and other mobile OSes added so many restrictions on what one can do for the sake of security (even though there are still more pressing security issues present) that many frameworks do not keep up with adding workarounds or using the new APIs.

Joplin is using react-native on mobile. Background processes are not easy to accomplish with that framework. Additionally, Android freezes apps in the background. Thus even if we had background sync, the OS would kill it.

Please thank Google and Apple for making development for mobile devices a living hell.


Only certain vendors like Huawei, and it can be disabled.

Android 10+ (10, 11, 12) on Google Pixel (1 and 5) does it as well, but there's on option to turn that off. But I remember experiencing issues even though it was turned off.

e.g. I have turned it off for DAVx5, K9-mail, and Signal, but sometimes I still receive mails only when I take the phone in my hands. (I use my own mail server with push notifications.)

There's a list of phones that do that here: