Homepage    |    GitHub    |    API    |    Wiki    |    FAQ

Joplin Error

Any Ideas?

Error
The sync target could not be upgraded due to an error. For support, please copy the complete content of this page and paste it in the forum: https://discourse.joplinapp.org/

The full error was:

Could not upgrade from version 2 to version 3: Lock has expired

Error: Could not upgrade from version 2 to version 3: Lock has expired
    at LockHandler.<anonymous> (/tmp/.mount_JoplinOFzevj/resources/app.asar/node_modules/@joplin/lib/services/synchronizer/LockHandler.js:301:25)
    at Generator.next (<anonymous>)
    at fulfilled (/tmp/.mount_JoplinOFzevj/resources/app.asar/node_modules/@joplin/lib/services/synchronizer/LockHandler.js:5:58)
    at processTicksAndRejections (internal/process/task_queues.js:95:5)

What Joplin version(s) you're using? Are there any discrepancies in versions on mobile and desktop (like 2.4.2 on desktop and 1.6.5 on mobile)?

Did you upgrade any version recently and got this error after the installation?

Any information on specifics of your cloud? Is it set up? is it local? is it on a network drive?

Version 2.5.12. No mobile version. Only a linux version, trying to sync with Nextcloud

Have all your devices including the server the correct time?