Joplin continuously synchronizes while entering notes

Ver: Joplin for Desktop 2.12.7

Joplin keeps syncing all the time while inputting notes, which makes me very concerned about the impact on performance, and continuous synchronization can also interfere with writing

The original intention of developers is to synchronize notes in real-time after modification, ensuring that the data on the server is always up-to-date But the actual situation is that after editing the notes, waiting for real-time synchronization to complete, and then clicking on synchronization, there is still data that has not been synchronized.

Suggestion: Cancel editing real-time synchronization and add automatic synchronization on exit on the basis of scheduled synchronization.



I, too, have noticed the negative impact of real-time/auto sync, especially when editing a table (Windows 11), and would prefer to have the option of turning it off since I still have to do manual sync in order to ensure full syncing of data.

1 Like

Windows 11 pro 22H2.
Joplin 2.12.7

I can see that too. As soon as I type a letter, Joplin launches an update (I think it's not a sync, just the database). It's a bit disruptive.

Ah, I see. Thanks. I hadn't understood the difference between an update and a sync. Then I guess I'm asking to make the constant auto-updating an option. Perhaps this is possible: manually pressing the synchronize button starts an internal update to the database and when that's successfully done, Joplin syncs to the internet. For me, I think that'd be a fool-proof method that eliminates the lag and also doesn't create conflicts on different devices.

In which way is it disruptive, is it because the sync icon is turning?

No, I don't think it's because of the sync icon turning. I notice the lag only when I'm typing in the non-MD editor in a table; after I type something, the update process starts and for 4-5 seconds, Joplin doesn't respond to any keyboard input. Then after I type another letter, then the update starts and again I have to wait 4-5 seconds to type. Perhaps it's related to my plugins? I have MultiMarkdown Table Tools and also Markdown Table: Colorize installed. Also, I use the Remoods Theme.

I just disabled those two plugins, but I didn't see any improvement.

What happens if you set the sync target to "None" or switch off the wifi connection? Does it still slow down? Because I'd expect sync doesn't use much resources, and that the slow down is due to the note being rendered, especially if it's a large note

Niether has any effect. And my note is tiny, with no media whatsoever.

I think the slowdown has to do with the update, not the sync.

Do you have many tags or many notebooks?

12 notebooks and maybe around 200 tags?

There's a chance it's due to the tags being updated. We have a performance issue with the tags and the more there is the slower the app gets

1 Like

So that would be an argument for giving the option to update the database manually.

I am also having serious performance problems since updating to the 2.12
Joplin continuously synchronizes while typing, which interrupts the writing flow and
from time to time, words are even lost, or the editing continues from the top.

The number of tags did not change; therefore, I would not assume that this is the reason.

Previously I encountered the same performance problems on slower machines, but to see it happen now on my main device makes me quite afraid, to be honest.

Why not enable manual sync, as is the case on the mobile version?

Do you also have many tags?

I have around 100 tags but the number did not change since I updated.

What are you all syncing with?

joplin cloud on my side

Could you provide your list of plugins? What if you run in safe mode? (Help => Safe mode)

I tried the safe mode and also deleted 50 tags but the synchronization issue seems to persist

Hmm, I don't understand how it's possible at this point. Sync does almost nothing so it shouldn't cause any slow down, and that number of tags is also not a problem. Which editor do you use? The Markdown one or the Rich Text one?