Joplin Console version help needed

OS is OpenSuse Leap 15.1
Joplin 1.0.201 App Image

I am interested in using the cli version of Joplin. While the GUI is working well on OpenSuse Leap 15.1.
I cannot see how to get the Console Version running. The following is my attempt to install Joplin in the console. Meanwhile the app.Image GUI version works ok.

NPM_CONFIG_PREFIX=~/.joplin-bin npm install -g joplin
npm WARN deprecated request@2.88.2: request has been deprecated, see https://github.com/request/request/issues/3142
npm WARN deprecated urix@0.1.0: Please see https://github.com/lydell/urix#deprecated
npm WARN deprecated resolve-url@0.2.1: https://github.com/lydell/resolve-url#deprecated
/root/.joplin-bin/bin/joplin -> /root/.joplin-bin/lib/node_modules/joplin/main.js

sharp@0.23.4 install /root/.joplin-bin/lib/node_modules/joplin/node_modules/sharp
(node install/libvips && node install/dll-copy && prebuild-install) || (node-gyp rebuild && node install/dll-copy)

internal/modules/cjs/loader.js:638
throw err;
^

Error: Cannot find module ‘/root/.joplin-bin/lib/node_modules/joplin/node_modules/sharp/install/libvips’
at Function.Module._resolveFilename (internal/modules/cjs/loader.js:636:15)
at Function.Module._load (internal/modules/cjs/loader.js:562:25)
at Function.Module.runMain (internal/modules/cjs/loader.js:831:12)
at startup (internal/bootstrap/node.js:283:19)
at bootstrapNodeJSCore (internal/bootstrap/node.js:622:3)
gyp ERR! configure error
gyp ERR! stack Error: EACCES: permission denied, mkdir ‘/root/.joplin-bin/lib/node_modules/joplin/node_modules/sharp/build’
gyp ERR! System Linux 4.12.14-lp151.28.44-default
gyp ERR! command “/usr/bin/node10” “/usr/lib64/node_modules/npm10/node_modules/node-gyp/bin/node-gyp.js” “rebuild”
gyp ERR! cwd /root/.joplin-bin/lib/node_modules/joplin/node_modules/sharp
gyp ERR! node -v v10.16.3
gyp ERR! node-gyp -v v3.8.0
gyp ERR! not ok
npm WARN jsdom@15.2.1 requires a peer of canvas@^2.5.0 but none is installed. You must install peer dependencies yourself.
npm WARN ws@7.2.5 requires a peer of bufferutil@^4.0.1 but none is installed. You must install peer dependencies yourself.
npm WARN ws@7.2.5 requires a peer of utf-8-validate@^5.0.2 but none is installed. You must install peer dependencies yourself.

npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! sharp@0.23.4 install: (node install/libvips && node install/dll-copy && prebuild-install) || (node-gyp rebuild && node install/dll-copy)
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the sharp@0.23.4 install script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR! /root/.npm/_logs/2020-05-06T06_55_01_622Z-debug.log

You might want to report this on the Sharp repository as I’m not sure if they support OpenSuse.