Is there a way to export notebook by id?

I found under explanation, by failed to export.

export <path>

    Exports Joplin data to the given path. By default, it will export the 
    complete database including notebooks, notes, tags and resources.

    --format <format>      Destination format: jex (Joplin Export File), raw 
                           (Joplin Export Directory), json (Json Export 
                           Directory), md (Markdown), html (HTML File), html 
                           (HTML Directory)
    --note <note>          Exports only the given note.
    --notebook <notebook>  Exports only the given notebook.

The command I used is:

joplin export TEMP --format md --notebook id

Thanks in advance!

What's the error?

Hi @laurent I'm now using joplin version 1.2.6.

When I using 1.1.4 joplin termianl not work which has been fixed by

For now, command joplin export TEMP --format md --notebook notebook_id only returns:

can't find notebook_id

All my notes are created by joplin GUI. But for some reason I don't know a notebook can't show in GUI, but still there in disk.

So I tried to use terminal joplin export it.

Could terminal joplin access notes created by GUI?

I find ways to let GUI share notes to terminal: joplin export --profile ~/.config/joplin-desktop ~/TTTT --notebook fa74fb3afbec4ae0a3d5344725ab0f50 --format md.

But still get can't find fa74fb3afbec4ae0a3d5344725ab0f50.