Integrate with system

Each time I start Joplin , Iget
'Would you like to integrate …with your system?.."
How can I get rid of this notification ?

1 Like

Pretty sure that is a system thing, and not because of Joplin, so you need to look into the settings of your system.

(I assume this is a Ubuntu flavor since I get the same)

I does not have ubuntu , but debian UN STABLE (SIDUCTION)

If it is system setting : then ALL APPIMAGES must have the same behaviour, but it is not the case.

Developper just add what they want .

Indeed this is something that can be disabled during the build process, but it is a feature that some people use. If you select yes the pop-up won’t reappear until you update Joplin.

Alternatively if you update Joplin using the update and install script, this pop-up shouldn’t appear at all, of it does that’s a bug and please report it.

Just set environment variable APPIMAGE_SILENT_INSTALL:


I just use a copy of application image , no built of other things , so …
less use of Joplin

If you set the environment variable APPIMAGE_SILENT_INSTALL in your login profile, you’ll never be bothered again.

Where to do that , I download appimage and copy it to directory and then run it