Home / GitHub Page

How to run android app using reactnativeclient

hi,
I am trying to run Joplin on the windows I have react native but I am getting errors
I have tried following commands-
files downloaded from Github
unzipped in the folder - joplingsoc
cd joplingsoc
npm install
cd ReactNativeClient
npm install
react-native run-android
I do have android emulater its working on other react projects

What errors are you getting? Is it the same error each time?

yes can you tell me from start how to run I think i am doing something wrong i have checked build.md still didnt get it.

Can you post the error you’re getting?
Are you on Windows 10?

yes
cd joplingsoc
npm install
then error
image

To test the mobile application you follow these steps from BUILD.md:

Testing the Mobile application

First you need to setup React Native to build projects with native code. For this, follow the instructions on the Get Started tutorial, in the “React Native CLI Quickstart” tab.

Then:

cd ReactNativeClient
npm start-android
# Or: npm start-ios

To run the iOS application, it might be easier to open the file ios/Joplin.xcworkspace on XCode and run the app from there.

Normally the bundler should start automatically with the application. If it doesn’t run npm start .

Have you tried this?

yup
Capture


Capturesssss

Did you try the troubleshooting options at the bottom of the BUILD.md file?

On Windows

If node-gyp does not work (MSBUILD: error MSB3428: Could not load the Visual C++ component “VCBuild.exe”), you might need to install windows-build-tools using npm install --global windows-build-tools.

If yarn dist fails, it may need administrative rights.

If you get an error MSB8020: The build tools for v140 cannot be found. try to run with a different toolset version, eg npm install --toolset=v141 (See here for more info).

And for the second screenshot, try “npm run start-android” instead.

after using react-native run-android this command in ReactNativeClient folder i am getting this error

I got the same error yesterday. Try and run it 3 or 4 times, you should get a different error each time, but eventually it should work. Let me know how it goes.

Edit: Also make sure you’re running CMD as Admin

ok lets see thanks for your help

hey i am getting this error in node terminal

I haven’t seen that error before, sorry. I’m not sure how to handle it.