Help neeeded: software clashes

Operating system

Windows

Joplin version

2.14.22

Desktop version info

Joplin 2.14.22 (dev, win32)

Client ID: 7e9a673e3f7140fa8afdd2f415269980
Sync Version: 3
Profile Version: 46
Keychain Supported: Yes

Revision: e579eb9

Backup: 1.4.0

Sync target

OneDrive

Editor

Rich Text Editor

What issue do you have?

A. The problem:
Joplin crashes when in use. It doesn't work at all.

B. The detailed problem:
After opening Joplin, it crashes and shows a pop-up window after several seconds without doing any operation.
Using some operations in the menu bar also leads to Joplin crashing.
Dev mode can be used (C:\Users\chenguanbin\AppData\Local\Programs\Joplin\Joplin.exe --env dev).

C. joplin_crash_dump_<DATE_TIME>.json and screenshots:
Link to shared files
I can't send links here. It contain sereval 'joplin_crash_dump' json file.

D. My goal:
Joplin can be used.

E. The methods I have tried, and they don't work:

  1. Used safe mode.
  2. Closed joplin.exe in Task Manager.
  3. Restarted the computer.
  4. Uninstalled Joplin and reinstalled it, both using the newest version of Joplin. The previous article data exists in Joplin.
  5. Closed OneDrive.

F. The methods I have not tried, also they are useful I guess:

  1. Try another version of Joplin.
  2. Empty the cache of Joplin after uninstalling it.
  3. Empty article data.

G. The reason that led to the problem (I guess):
The previous operations included using an Edge extension to save an article.
Maybe an HTML file is too large, which led to Joplin crashing.
The previous operations also included dragging local website files into Joplin.

Screenshots

software clash.png

I can't send links here. It contain sereval 'joplin_crash_dump' json file.

update:
I guess it was visiting a very large HTML file that led to the problem.
The problem is solved now. I don't know why. At one point, the software did not crash. However, after visiting a certain large HTML file, it crashed, but it could still be used after reopening it.
Maybe I downloaded a new executable file from the website and reinstalled it, or I installed Joplin on different computers and used OneDrive to sync it.
After I deleted the very large HTML files, the software totally can be used now.