Homepage    |    GitHub    |    API    |    FAQ

File locked Variation

Hello everyone
I know there's a lot of topic about file locked issue with nextcloud, and that Nextcloud is the problem. Ok
As I didn't install Redis for now I face the issue several times (more and more often... ) and was able to solve the issue with this

But now here's a tricking thing : I can't find the file locked (it not appears in Joplin/lock so I can't unlock it.

System : Ubuntu 20.0.4
Joplin's version : 1.8.5 (prod, linux)
Sync version : 2
Revision : b28f087

Nextcloud : version 20.0.7

last error message after sync in joplin :
Terminé : 12/05/2021 15:38

Dernière erreur : Error: PUT locks/sync_desktop_b5712727fffa41319311b91207c9a7cf.json: "xxx/files/Joplin/locks/sync_desktop_b5712727fffa41319311b91207c9a7cf.json.upload.part" is locked (Exception OCA\DAV\Connector\Sabre\Exception\FileLocked) (423): <?xml version="1.0" encoding="utf-8"?> <d:error xmlns:d="DAV:" xmlns:s="http://sabredav.org/ns"> <s:exception>OCA\DAV\Connector\Sabre\Exception\FileLocked</s:exception> <s:message>"xxx/files/Joplin/locks/sync_desktop_b5712727fffa41319311b91207c9

Any clue?
Thanks!

addendum :
I'm still stuck here. .. and I'm so tired with those sync issues with Nextcloud*...
I find that the famous file locked was in the trash on my nextcloud server, so I restored it (I know this is certainly quite not orthodox.. ), and sync was ok then (while very slow but one thing at a time)
BUT, then the file returned into the trash and the situation went back to initial issue. Is it a Joplin or Nextcloud issue?
Without this file there's no sync between the android client and the linux desktop client
thanks a lot for any response

Nextcloud locking mechanism is broken by default so you'll keep having issues till you add Redis. All Joplin is doing is reading/writing/deleting files, which are basic operations that should be well supported in any proper cloud file storage. At Nextcloud unfortunately they have other priorities than getting basic stuff to work.

1 Like

thanks for your answer.
yep I think I understand that now.
I'll try to do that (certainly quite simple for you all here but .. I just wanted to write notes you know I don't know anything about code and cache memory and so on)
Anyway thousand thanks for your appli

I think you indeed have to know about all this if you're considering self-hosting. Also if all you need is note synchronisation, perhaps have a look at Joplin Server as it works better than Nextcloud for that purpose.

This is the problem. The threshold of Joplin Server causes ordinary people and even developers to not or unwilling to use it. . . Does Joplin Server have a paid hosting plan?

I think you indeed have to know about all this if you're considering self-hosting.

Oh yes I know, well I don't really know (haha) but I can see that and .. well I make some efforts and give several dozens hours

actually my problem is that I'm not really self-hosting, I have a hosting on a server that I pay for, on wich I install Nextcloud . So I finally get that I can't install Redis because of this as I understand it because it has to be done on server side and this is out of my hands.
And now I don't know if I can install Docker for Joplin Server, besides a nextcloud instance.
But this you can't answer I know

Anyway I'm still on the same step : sync disable because of this ** file locked that is deleted no matter how many times I restore it.
Is it a reinstall case or is there any config file or similar that I could reset maybe?

If this is a server managed by a company, they should do something about it then. Their Nextcloud installation doesn't work and if you don't have the access to fix it, then they should.

Is it a reinstall case or is there any config file or similar that I could reset maybe?

No, Nextcloud is broken without Redis so resetting won't change anything.

1 Like

Hi,

I also had the file lock error and couldn't install redis on the server.

What fixed it for me was making sure there are no left out cron jobs on the nextcloud. Turned out some tasks have not been carried out for days. Fixing this (with webcron) lets me use Joplin without syncing error (or very short syncing errors, that get corrected quickly).

Hope it helps :slight_smile:

Best

Hi
thanks for the tip. Well from what I see, not this problem for me.
I resolved the problem like this (I was waiting to see if it works before posting something) : I don't remember the post I saw, and I can't find it. I just remember it was about making sync faster. The tip was to sync not directly with the cloud, but with the desktop file wich is sync with the cloud.
So I change my target for sync from the nextcloud webdav adress to the file on my desktop wich is sync to nextcloud.
For now it seems to work properly .... between my linux laptop and my android tel
I still get troubles with the Imac install : it now opens normally (I had white window issue) but no more sync, it is stuck one month ago. I will try to modify the sync target as I did for the laptop linux.