Export PDF has extra title line

OS: Win 11
Version: 2.8.8

Hello, guys!
I found that exported pdf have an extra title line as Primary title.
And below is pdf.

Here you can see extra title line:1. Welcome to Joplin!
Could you help that let Joplin don't add this extra line?
Thank you very much.

The first one is the note name, and the second one is the H1 heading. It is a default setting, nothing wrong here. If you don't want it duplicate, there are three solutions.

  1. Remove the H1 heading.
  2. Use H1 for a different headline.
  3. Use external CSS to hide the note name.

About the third one:

  1. you should go to tools > options > appearance > show advanced settings > Custom stylesheet for rendered markdown
  2. It wil open a userstyle.css file.
  3. copy the below code
@media print {
  .exported-note-title {
    display: none;
  }
}
  1. paste it to your userstyle.css and then save & close it
  2. quit & restart Joplin
  3. export the note again, then you will see it is gone.
3 Likes

Thank you! The third solution works well.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.