Error importing notes from format: enex

Operating system


Joplin version


Desktop version info

Joplin 2.13.13 (prod, win32)

Client ID: 49b0934174a14933ad1678e68bcf28b7
Sync Version: 3
Profile Version: 44
Keychain Supported: Yes

Revision: c3cdeeb

What issue do you have?


  • Input format: enex
  • Output format: html


Line 50393:0: "Audiology Associates - Replacement Hearing Aid": Unclosed root tag
Line: 50393
Column: 0


Joplin Support - Import Failure - 2 - 2024-01-22.jpg

Thanks for the report. If you export just the note "Audiology Associates - Replacement Hearing Aid" as ENEX and import it, does it also show an error? And if so would you be able to share that file (either here or via PM is fine)?

I was able to import the note you mentioned using Import --> ENEX Markdown and it went fine.
I also was able to import the note as part of a notebook using the same import (Import --> ENEX Markdown) and it went fine,

I might have tried importing using Import - ENEX HTML when it failed.

I tried importing just that note as markdown and html and both succeeded. The content of the note is this:

"July 13, 2015 94714 PM PDT.png"

It is just a screenshot of some patient information. I'm not sure that note was the one that had the problem. There are four other notes in the notebook in Evernote.

I also reexported from Evernote the notebook with five notes and Reimported as both HTML and markdown and both imports (notebooks) succeeded. No hang-ups.

I think there were two issues:

  1. That the import hung Joplin and there was not clear/obvious way to get around it.
  2. Something wrong (???) with one of the notes in the notebook

To get around it, I killed the Joplin process (windows 10) and then restarted it.

Bottom line; I no longer have the problem and don't know why. And I can't reproduce it now. You can close the ticket.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.