Desktop Client Linux Mint/Ubuntu?

I went through the installer using npm. I don’t see an option to launch gui for joplin just the command line. Is there anyway to launch the desktop on linux?

The terminal client worked as expected. Just can’t figure out how to launch the non terminal version as the instruction are not 100% clear. I see slack I believe is joplin-desktop and it will run.

Desktop version is not installed via npm, you need to download the installer (or AppImage) from the main website.

I ran appimage and it runs but didn’t find what I had already created using terminal app. I cannot find an installer for linux on the site. I only see the method to install as npm and appimage.

For some reason I think after running appimage the npm installed version is now gone. I was running it and taking notes just fine now it does not exist.

The cli app and desktop app are two separate applications that do not share the same data. If you want to see the same data in both, you need to set them up so that they sync to the same target.

The terminal app is still there normally, you can bring it up by typing “joplin”. If not, try re-installing it, and it should show the notes you’ve already entered (they are saved in ~/.config/joplin )

Under config I see joplin and joplin-desktop.

Do you think launching joplin via appimage caused issue with jopling command line?

Also need to try and better understand your comment about downloading the installer?

  1. NPM - I see this as one of the methods for installing and not sure what this actually is. But I did follow the guide and it installed it worked until I ran AppImage.
  2. AppImage - This is just like a portable app from what I can tell.
  3. Installer(you mentioned) - I cannot find this on the site for Linux.

Under “Installation”, there are three sections:

  • Desktop applications. To get the desktop app under Linux download the AppImage file. There’s currently no other installation method.
  • Mobile applications.
  • Terminal application: These are the instructions to install the terminal app only.

Do you think launching joplin via appimage caused issue with jopling command line?

No it’s probably something else, they don’t conflict with each others.

npm install -g joplin
/home/dconepc/.npm-global/bin/joplin -> /home/dconepc/.npm-global/lib/node_modules/joplin/main.js

  • joplin@1.0.106
    updated 1 package in 11.246s
    dconepc@userone ~/.npm-global $ joplin
    joplin: command not found

For some reason it won’t launch anymore even thought it is installed anyone got any ideas?

This fix was to just to reinstall using this and now I can see my notes again.

NPM_CONFIG_PREFIX=~/.joplin-bin npm install -g joplin
sudo ln -s ~/.joplin-bin/bin/joplin /usr/bin/joplin