Home / GitHub Page

Desktop: Can't get "Custom TLS Certificates" to work

#1

I am syncing Joplin with a private NextCloud instance.
The NextCloud server has a TLS certificate signed by a private CA.

I have installed the certificate for the private CA in Firefox and can connect to NextCloud over HTTPS from Firefox without problem (both Windows and Linux).

I have installed the certificate for the private CA in Thunderbird and can sync from Thunderbird to CALDAV and CARDDAV over HTTPS without problem (both Windows and Linux).

I have installed the certificate for the private CA in Android and can connect to NextCloud over HTTPS from Chrome, to CALDAV and CARDDAV over HTTPS from DAVx5, and sync Joplin (since version 1.0.248) over HTTPS, all without problem.

But for syncing Desktop Joplin (version 1.0.151, both Windows and Linux) over HTTPS, I have to enable
the “Ignore TLS certificate errors” option. I tried setting the “Custom TLS Certificates” option to point to a
copy of the certificate for the private CA, and it makes no difference.

Any thoughts what I could be missing or doing wrong?

Regards,
MV