Home / GitHub Page

Dependency on canberra

I’m using Joplin on a Fedora Silverblue 31. It works mostly fine, but there’s a specific thing that I think could be improved.

At the start of the app’s boot, I see this on the console:

Gtk-Message: 12:59:34.882: Failed to load module "canberra-gtk-module"

I got rid of this by checking who provides this (dnf provides libcanberra-gtk-module.so), which apparently is libcanberra-gtk2, in my case. A sudo dnf install -y libcanberra-gtk2 made the problem go away.

I feel like this is a packaging problem, and should prolly be solved there. I’ve installed it through taw’s Copr repo. Does anybody know how to get in contact with this person?

Why would Joplin ever want anything to do with sound? Perhaps the best call would be to remove this entirely?

Thanks for bringing this up, @pkoch. This isssue is not a Joplin specific one but instead was created by the repo’s maintainer. And, after doing a quick search, it looks like taw doesn’t have any contact information tied to that repo, so it doesn’t look like there’s any direct way to contact them. Joplin doesn’t use any gtk modules or anything specific to Linux outside of what Electron requires to function.

I’m sorry I wasn’t of much help otherwise.

Yeah. :confused: I’m only using this person’s Copr since that seems to be the easiest way to get Joplin working in Fedora. However, I see that you’ve been trying your luck at a flatpak on https://github.com/laurent22/joplin/issues/738. I’ll subscribe to that issue instead!

Thank you for your time, @bedwardly-down!

Don’t worry about that post. I was testing but couldn’t get it working, so I haven’t touched it since.

When you say that you’re having problems getting Joplin to work, are you saying the official AppImage isn’t working for you? And also, since you’re on Fedora 31, have you checked this post out yet?

When you say that you’re having problems getting Joplin to work, are you saying the official AppImage isn’t working for you?

Oh! I managed to overlook that! Will try it out, thanks!

And also, since you’re on Fedora 31, have you checked this post out yet?

I’ve been using that Copr repo, not the AppImage (not that it should make a difference, but :man_shrugging:) . However, I am running 5.5.7-200.fc31.x86_64 and I didn’t run into any lock-ups.

Just noticed the wget -O - https://raw.githubusercontent.com/laurent22/joplin/master/Joplin_install_and_update.sh | bash instruction on the README. I feel dumb. :man_facepalming:

Nothing to see here, thanks for the help!

1 Like

No worries. Feel free to stick around the forums here and any further issues, reply and we’ll see what we can do.

1 Like

I think this is who you’re looking for: https://github.com/laurent22/joplin/issues/2682

Yup. And he goes by @t0dd on the forums. :smiley: Thanks

Yup. I am taw on the fedora project sites, taw00 on github, and t0dd everywhere else. :slight_smile:

You are saying I’m missing a dependency? Or at least a dependency that gets rid of that annoying message? I will experiment.

UPDATE1: I don’t see that error. What are you doing to generate it @pkoch, just installing? If so, I will add that dependency. My base Fedora desktop install has that RPM already installed so … I didn’t see it. And no one else complained.

UPDATE2: I added contact information at the COPR site and a link to the github repo where I develop the SPEC file and such.

2 Likes

Yep, I just installed it. It was inside a toolbox, in a Silverblue install. Unsure if that changes the expected packages.

Thanks for updating! :two_hearts: