Debian 10 installation not running


I try to run joplin on debian buster with a raspberry pi desktop.

But after the install I receive an error. I could not fix. :frowning_face:

Regarding my system:

cat /proc/version
Linux version 4.19.0-16-amd64 ( (gcc version 8.3.0 (Debian 8.3.0-6)) #1 SMP Debian 4.19.181-1 (2021-03-19)

I have tried the installation with:


If I try to start joplin via the icon. I get an error message :boom::

Failed to execute child process “/home/pi/.joplin/Joplin.AppImage” (No such file or directory)

But the appimage is in the right location and executable :disappointed:

pi@raspberry:~ $ ls -alh /home/pi/.joplin/Joplin.AppImage
-rwxr-xr-x 1 pi pi 141M Jun 16 19:33 /home/pi/.joplin/Joplin.AppImage

If I run the installation command twice i read in the output

The latest version is 2.0.11, but you have no version installed.

I am obviously not a expert on linux and do not know how to fix it.:worried:
Thank you in advance for any kind of help.

@wadam welcome to the forum.

If this is the Raspberry Pi Desktop for PC I notice that the ISO is named:


So I am wondering if they may be using a 64-bit kernel (hence the cat /proc/version output) but on a 32-bit system? (ie using a 32-bit system similar to that used by RasPiOS on ARM). I believe that the AppImage does not run on 32-bit.

Just a guess :slight_smile:

kernel should be 64 bit

cat /proc/version
Linux version 4.19.0-16-amd64 ( (gcc version 8.3.0 (Debian 8.3.0-6)) #1 SMP Debian 4.19.181-1 (2021-03-19)

So I guess the topic with 32 bit and the appimage should not be the problem

My point was that the kernel may be 64-bit but the system and its libraries may not.

how could it look for that?

I don't know. That's what I am trying to find out at the moment! :slight_smile:

I do not know if:

pi@raspberry:~ $ uname --m

does the job?

getconf LONG_BIT shows 32 which I think means that the system itself is actually 32-bit despite the kernel being 64-bit....

Your are right

pi@raspberry:~ $ getconf LONG_BIT

Is there an other way to install joplin then the appimage?

There are unofficial versions (such as Flatpak) but I don't think that any of them will overcome the fact that the Raspberry Pi Foundation has built their Debian Desktop OS as 32-bit and Joplin requires 64-bit.

The issue of 32-bit has arisen before and does not appear to have been resolved by anyone who wants to run Joplin on a 32-bit OS.

Assuming you want to keep with this OS a check of the RasPi downloads server shows only rpd_x86 so a 64-bit Raspberry Pi Desktop for PC does not appear to be an option either.

The Joplin AppImage works fine on Linux Mint :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.