Changed Joplin folder location, PDFs no longer open on Android

I'm running the latest version of Joplin on Linux (2.5.12) and also on my Android (v11) phone (2.6.3). Until recently, everything was wording splendidly. I hosted my Joplin repository on Nextcloud and all was well.

And then I switched the location of my files from a Nextcloud folder to OneDrive.

Everything is still working very well with one major exception: I can not longer open any PDF files in the Android app. I've added notes with PDF attachments both in the Android app and in the Joplin linux app, and never had this problem. I can still attach PDFs in the Android app and can view them in the linux app, but if I try to open a pdf in the Android app, I now get the message:

No app associated with this mime type.

This is for any PDF attached either in the Android app or the Linux app. I've tried removing and readding PDFs and I get the same result.

I have searched the forum here and the only other example that seems to approximate my situation is where another user imported his markdown files from another app into Joplin. That wasn't my problem. Can anyone help me?

1 Like

This was fixed today actually:

THANK YOU! That's great news. Will be looking for the update to kit the Play Store.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.