can't sync between devices?

Operating system

Linux
Android

Application

Desktop
Mobile

I don’t know if this was already addressed:

I can’t synchronize joplin between devices.
it does synchronize with nextcloud.

I use the same webdav url, username and password between devices however the devices do not synchronize.

is it possible to synchronize joplin between devices?
thanks

If you search the forum, you will find several posts that all end up being user errors. Joplin was designed to sync between devices.
I am using Nextcloud to sync between Linux Terminal CLI, macOS Desktop, Android, and iPad. It works perfectly.

I don't know, if you have ever written a usability question, but that's not how you do it. I mean we have no information about your environment, Joplin version, error message, debug log. Nothing.

So the only thing we can do is the following:

Yes.

great!

how do you sync between devices?
I have entered the the same webdav url from nextcloud on my android and on my linux desktop app.
I use the latest version on both devices.

It does not sync, I don’t know how to set it up properly.

the syncing works however, it does sync with nextcloud, but not between devices. could somebody help me set it up please

alright update:
not all notebooks are synced.
Sync from android to desktop works, however syncing on android gives an error:
Error uploadblob
Error: javax.net.ssl.SSLProtocolException: SSL Handshake aborted
failure in ssl library usually a protocol error

syncing on desktop does not give any error.

another update: I can’t read encrypted notes from android on desktop, but it does find them. any solution?

Looks like maybe you made a mistake with your master key? Maybe try entering it again?

There can be a bunch of reasons why this is happening. Old Android version, misconfigured server, ...

Yet, we still don't have a debug log or a low level Android adb log. Nor do we know which Android version you are using. What does the server ssl log tell you?

Android version 4.2.1
kernel version: 3.4.5
android joplin version: 1.0.255
Database: v22
33

desktop linux joplin version: 1.0.157

problem:
Android to desktop sync works
desktop to android sync does not work
can not decrypt notebook from android on desktop.

Android version 4.2.1
kernel version: 3.4.5
android joplin version: 1.0.255
Database: v22

Android version 4.2.1
kernel version: 3.4.5
android joplin version: 1.0.255
Database: v22

desktop linux joplin version: 1.0.157

enabling encryption does not work in my experience because it creates a different key than the key that was used to encrypt on the android.
the key used on android to encrypt the notebook is at the bottom, but I can’t enter my password.

Can you configure the android client to use an http: connection (not https:)?
There’s a problem with certain custom certificates.

I changed the webdav url from https to http, testing right now to sync.

however is it possible to update ssl certificates in android through adb? I don’t know how but I think this may solve it.
update:
still errors, but different errors. I can’t reply for today (maximum replies) but it has something to do with headers this time.

update:
I just rooted my phone, then installed a cacert app to install new ssl certificates.
then I rebooted the phone.

still same problem though.

Ok, I'm seriously confused by what you are saying: First you say that

But then you say that

So what is it?

You never sync from on device to another device. You sync a device (or the desktop app) to a sync target (which is your nextcloud). So your desktop (Linux) and your device (Android) sync with the nextckloud server.

The SSL on Android has to to with Android version <= 4.4.

The first entries when you search for that error are these:

So what's happening is this: You probably use TLS 1.3 or certain ciphers on the server which are not available on your old Android device. There are 2 options (none of which have anything to do with Joplin btw):

  1. Upgrade Android OS to a version that includes the SSL/TLS protocol and ciphers used by your server
  2. Change the server configuration to allow ciphers and protocols which are available on your Android