Build Error on Windows & Linux(Arch)

Joplin version: 1.7.11
Platform: Windows & Linux (Arch)
OS specifics: x64 bit

Steps to reproduce

  1. git clone source
  2. install dependencies
  3. npm install

I tried removing the spaces and also moving to a new directory with no spaces, as suggested by @roman_r_m @JackGruber and on previous topics related to build errors. But it still fails to build the source.

cmd error - --> cmd error output
2021-03-25T17_32_46_537Z-debug.log - --> 2021-03-25T17_32_46_537Z-debug.log
2021-03-25T17_32_47_524Z-debug.log - --> 2021-03-25T17_32_47_524Z-debug.log

Perhaps try Node 12

Or try installing windows build tools like this

npm install --global windows-build-tools --vs2015
1 Like

Yes! this worked. Although initially I had removed node completely and re-installed, but pretty sure this was the issue.
Thanks @roman_r_m

Just in case...

(referenced here joplin/ at dev · laurent22/joplin · GitHub)

yes, I had found it later today. But it still wont build on Arch, after searching a bit, found out it could be an issue with the packages and official support wouldn't be there, I guess according another article I read. So I'll continue with windows

The link is just for reference. If you have a problem that isn't fixed by any of the solutions in the troubleshooting file, we should update it accordingly.

Although I hoped people would just open PRs with their solutions along the way... :wink:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.