[BUG] Webdav Sync Not Working anymore on iOS

Hello everybody,

I currently use different Joplin clients.

  • On my Mac (Version : OS X 10.15.7 (19H2)) with Joplin Version (1.2.6 (prod, darwin))
  • On my iPhone (iPhone 11Pro, IOS 14.2), with Version (10.3.1)
  • All my datas are on my Nas (ASUSTOR, with a Webdav Apache container)

Everything worked fine until some weeks now.
Mac OS Joplin client sync fine.

But iOS App do not sync anymore, always the same message (if i launch sync checking) : "Error. Please Check URL, etc....". I tried to set again 10 times url, login and password and no doubt they are fine.
I use https connectivity with an expired certificate , this is not a problem for Mac Client, could it be a problem for ios version ? I have really no idea.

Your help would be appreciated.

If the certificate is expired, can't you just renew it?

The desktop client can ignore the certificate, and the mobile terminal hopes to have this option.

Security is always tighter on mobile and you can't ignore certificates there. If you need that kind of low level hacking, it's best not to use an iPhone but to go with a rooted Android or similar.

Hello everyone, thanks for your answers. I will try to renew certificate (manual renewal of let's encrypt certificate is not that easy ) . I will keep you in touch. A.M.

Thanks everyone. It was it. Ios Client do not support outdated certificate at all. Thanks again to everyone.

PS : I cannot rename that thread to SOLVED.

But you can pick a comment as the solution. Click on the 3 dots and then on Solution.