BUG: Opening ahcnored section suddently jump to the top of the page

Operating system


Joplin version


What issue do you have?

Somtimes after I click a hyperlink that references a section within another note, Joplin first opens the the note at the correct location (where the anchored text is located), but then suddenly jumps to the top of the page.



In the gif above you can see that after opening note at the correction location Joplin suddenly jumped to the top of the page. Android version 2.12.3 doesn't have that problem.

PS: I also tried with all plugins disabled, just to be sure plugins weren't causing the issue, same behaviour.

I cannot reproduce the problem.

Here's the jex file with a reproducible example. Open the Registers page and click the least-significant byte hyperlink. It will open another notebook page at the correct location, but then suddenly jump to the top of the page.

assembly.jex (184 KB)

I tried your example - the link opens the Glossary note right to the top of that note (no jumping because it never starts at the anchor text in the Glossary note). Unless I need to enable something in my Joplin setup to have it work correctly with anchor links?

Is there a possibility you didn't notice the jump, because it happened quickly as in the gif? You can see in the gif, for a brief moment the note opens at the anchored title and then jump happens. All addons were disabled .
I can't be the only one who has this issue, right? :smiley:

Can you try it on mobile, because on mobile it opens at the correct location.

Now something very weird happened. I didn't change anything. I was using browser and when I switched to Joplin the hyperlink started working correctly. Something is wrong with Joplin :smiley:

If the initial jump to the anchor text is happening, the jump to the top of the note is happening so quickly that I don't see it. In your demo, I can clearly see the jump away to top of note. On my system, it just looks like target note opens to the top of the note.

Yes, this works on my iphone. It opens the target note, to the top of note, first, then jumps to the anchor text. Perhaps the desktop is supposed to work same way - i.e., jump to target note (top of note) first, then jump to anchor text?

If it works on iPhone & Android and doesn't work on Desktop then it must mean desktop version has a bug,
Should I open an issue on GitHub?

it seems someone has faced the same issue and has already open an issue on GitHub.

1 Like

If I disable the Automatic Backlinks to note addon, then Joplin hyperlinks start working correctly on the second try. So, after clicking the first time the page jumps to the top, but all subsequent clicks land to the anchored location. Here's the gif

Can somebody reproduce and confirm this?

I have had that plugin disabled for a couple of weeks (installed, but disabled), so that's the context for the behavior I described in earlier posts.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.